Помогите написать программу на Паскале для: x^2+4=0
Ответы на вопрос
//PascalABC.NET версия 3.4.0.1677 от 17.06.18
//Если программа не запускается, то обновите версию
var
x0, xk, dx, x: real;
function f(x: real): real;
begin
f := x * x + 4;
end;
begin
write('Введите промежуток и шаг ([a,b] h) ');
readln(x0, xk, dx);
x := x0;
writeln(' x ':10, ' | ', ' f(x) ':10);
repeat
writeln(x:10:3, ' | ', f(x):10:3);
x := x + dx;
until x > xk;
end.
Для решения уравнения x^2 + 4 = 0 на Паскале можно использовать следующий код:
pascalprogram QuadraticEquation; var a, b, c, discriminant, x1, x2: real; begin // Введите коэффициенты a, b и c writeln('Введите коэффициент a:'); readln(a); writeln('Введите коэффициент b:'); readln(b); writeln('Введите коэффициент c:'); readln(c); // Вычисление дискриминанта discriminant := b * b - 4 * a * c; // Проверка дискриминанта if discriminant > 0 then begin // Два вещественных корня x1 := (-b + sqrt(discriminant)) / (2 * a); x2 := (-b - sqrt(discriminant)) / (2 * a); writeln('Два корня:'); writeln('x1 = ', x1); writeln('x2 = ', x2); end else if discriminant = 0 then begin // Один вещественный корень x1 := -b / (2 * a); writeln('Один корень:'); writeln('x = ', x1); end else begin // Нет вещественных корней writeln('Нет вещественных корней'); end; end.
Эта программа сначала запрашивает у пользователя значения коэффициентов a, b и c, затем вычисляет дискриминант и определяет, сколько вещественных корней имеет уравнение. Результаты выводятся на экран. В вашем случае, так как уравнение x^2 + 4 = 0 не имеет вещественных корней, программа выведет "Нет вещественных корней".
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
