Вопрос задан 07.10.2023 в 19:33.
Предмет Информатика.
Спрашивает Васюткин Ярослав.
Задано целое число n напишите программу которая находит количество 0 в заданном числе.C++
Ответы на вопрос
Отвечает Иванова Алиса.
#include "iostream"
#include "stdlib.h"
#include "locale.h"
using namespace std;
int main(){
setlocale(LC_ALL, "russian");
int number; // число
int counter = 0; // количество 0
cout << "Введите число: "; cin >> number;
while(number > 10){
if(number % 10 == 0){
counter ++;
}
number /= 10;
}
cout << counter << endl;
system("pause");
return 0;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вы можете написать программу на C++, чтобы найти количество нулей в заданном целом числе, преобразовав число в строку и затем подсчитав количество символов '0' в этой строке. Вот пример такой программы:
cpp#include <iostream>
#include <string>
int main() {
int n;
std::cout << "Введите целое число: ";
std::cin >> n;
// Преобразовываем число в строку
std::string strNumber = std::to_string(n);
int count = 0; // Переменная для подсчета нулей
// Перебираем символы строки и считаем нули
for (char c : strNumber) {
if (c == '0') {
count++;
}
}
std::cout << "Количество нулей в числе: " << count << std::endl;
return 0;
}
Эта программа сначала преобразует введенное целое число в строку с использованием std::to_string(), а затем перебирает символы этой строки, подсчитывая количество символов '0'.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
