Вопрос задан 07.10.2023 в 13:56. Предмет Информатика. Спрашивает Шталь Андрей.

( Решить и Написать на паскале) Напишите программу, которая будет выводить на экран элементы

последовательности трибоначчи- первые элементы последовательности: 0,0,1,1,2,4,7,13,24,44 81,149.. . Каждый элемент, начиная с четвертого, равен сумме трех предыдущих: an= an-1 + an-2 + an-3
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Гетманская София.

//PacalABC.NET 3.4.2

//Используется формула аналогичная формуле Бине для чисел

//Фибоначчи

const

 index = power(33, 0.5);

 a1 = power((19 + 3 * index), 1 / 3);

 a2 = power((19 - 3 * index), 1 / 3);

 b = power((586 + 102 * index), 1 / 3);

var

 n: smallint;

function tribonacthi(n: smallint): biginteger;

begin

 if (n = 1) or (n = 2) then result := 0

 else

   result := RoundBigInteger(3 * b * ((power((1 / 3 * (a1 + a2 + 1)), n - 1)) / (power(b, 2) - 2 * b + 4)));

end;

begin

 try

   n := readinteger('Введите количество элементов для вывода:');

 except

   on system.formatexception do

     writeln('Неверный формат ввода');

 end;

 for var i := 1 to n do write(tribonacthi(i), ' ');

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Pascal для вывода элементов последовательности трибоначчи:

pascal
program TribonacciSequence; const N = 15; // Количество элементов для вывода var a, b, c, nextElement: Integer; i: Integer; begin // Инициализация первых трех элементов a := 0; b := 0; c := 1; // Вывод первых трех элементов writeln(a); writeln(b); writeln(c); // Генерация и вывод оставшихся элементов for i := 4 to N do begin nextElement := a + b + c; writeln(nextElement); // Обновление значений для следующей итерации a := b; b := c; c := nextElement; end; end.

Эта программа инициализирует первые три элемента последовательности и затем использует цикл для генерации и вывода оставшихся элементов, применяя формулу an = an-1 + an-2 + an-3. Вы можете изменить значение константы N, чтобы получить больше или меньше элементов последовательности.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос