Вопрос задан 07.10.2023 в 10:32.
Предмет Информатика.
Спрашивает Евдокимов Роман.
Напишите программу(Паскаль) заполнения массива A [1..20] произвольными числами в диапазоне [0,100]
Ответы на вопрос
Отвечает Куров Алексей.
program raf105;
var a:array[1..20] of integer;
i:integer;
begin
for i:=1 to 20 do
begin
a[i]:=random(0,100);
write(a[i],' ');
end;
end.
Язык программирования PascalABC
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на Pascal, которая заполняет массив A[1..20] произвольными числами в диапазоне [0,100]:
pascalprogram FillArray; var A: array[1..20] of Integer; i: Integer; begin Randomize; // Инициализация генератора случайных чисел // Заполняем массив A случайными числами в диапазоне [0, 100] for i := 1 to 20 do begin A[i] := Random(101); // Генерируем случайное число от 0 до 100 end; // Выводим заполненный массив на экран writeln('Массив A[1..20] заполнен случайными числами в диапазоне [0, 100]:'); for i := 1 to 20 do begin write(A[i], ' '); end; writeln; // Завершаем программу readln; end.
Эта программа использует функцию Randomize, чтобы инициализировать генератор случайных чисел, и затем заполняет массив A случайными числами в диапазоне от 0 до 100. Результат будет выводиться на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
