Помогите пожалуйста сделать программу движения какого либо предмета состоящий из 5 деталей в
паскале АБЦ,Самое главное что бы программа состояла из более менее понятных команд для ученика 8 класса) спасибо)Ответы на вопрос
Ответ:
Обьект "ракета" 1)Program raketa;
Uses GraphAbc; //Подключение модуля GraphAbc
Begin
SetWindowSize(500,500); //Установка размеров графического окна
SetPenColor(clBlack); // цвет пера -
Line(50,100,150,150);
Line(150,150,350,150);
Line(350,150,400,200);
Line(400,200,350,250);
Line(350,250,150,250);
Line(150,250,50,300);
Line(50,300,50,100);
SetPenColor(clRed);
Line(50,200,150,200);
SetPenColor(clBlack);
SetBrushColor(clSkyBlue );
Circle(200,200,20);
Circle(250,200,20);
Circle(300,200,20);
Движение "ракеты" 2)Uses GraphAbc;
procedure raketa(x:integer);
begin
Line(x,100,x+100,150);
Line(x+100,150,x+300,150);
Line(x+300,150,x+350,200);
Line(x+350,200,x+300,250);
Line(x+300,250,x+100,250);
Line(x+100,250,x,300);
Line(x,300,x,100);
SetPenColor(clRed);
Line(x,200,x+100,200);
SetPenColor(clBlack);
SetBrushColor(clSkyBlue );
Circle(x+150,200,20);
Circle(x+200,200,20);
Circle(x+250,200,20);
end;
var x:integer;
Begin
x:=5;
lockdrawing;
repeat
clearwindow;
x:=x+5;
raketa(x);
sleep(50);
redraw
until x>windowwidth
End.
End.
Объяснение:
ВНИМАНИЕ!!!
Я НЕ ОБЕЩАЮ ЧТО ОТВЕТ БУДЕТ ПРАВИЛЬНЫМ
Конечно, я могу помочь вам написать программу на языке Pascal, чтобы создать движение предмета, состоящего из 5 деталей. Ниже представлен пример программы, которая использует простые команды для ученика 8 класса. Эта программа создает анимацию движения объекта вверх и вниз:
pascalprogram Движение_Объекта; uses Crt, Dos; var i, x, y, direction: integer; begin x := 10; // начальная позиция по горизонтали y := 10; // начальная позиция по вертикали direction := 1; // направление движения: 1 - вниз, -1 - вверх // Очистим экран ClrScr; // Начнем движение объекта for i := 1 to 100 do // измените количество итераций по вашему желанию begin // Очистим предыдущее положение объекта GotoXY(x, y); Write(' '); // Переместим объект y := y + direction; // Отобразим объект в новом положении GotoXY(x, y); Write('#'); // Подождем немного, чтобы увидеть движение Delay(100); // Если объект достиг границы экрана, изменяем направление движения if (y <= 1) or (y >= 24) then direction := -direction; end; // Завершаем программу ReadKey; end.
Эта программа использует библиотеку Crt для работы с консолью. Она перемещает объект вверх и вниз по экрану и меняет направление движения, когда объект достигает верхней или нижней границы экрана. Вы можете настроить начальную позицию, скорость и количество итераций по вашему усмотрению.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
