Вопрос задан 05.10.2023 в 09:32.
Предмет Информатика.
Спрашивает Баженова Дарья.
помогите пожалуйста составить программу с помощью цикла с постусловием repeat... unti:1) дано
натуральное число верно ли что сумма его цифр больше 10? 2) найти сумму целых положительных чисел больших 30 и меньше 100.помогиите Ответы на вопрос
Отвечает Кайсанбекова Камшат.
Ответ:
привет. ты же учишься в Якутске? если да это я лиаанааа.ахахахахах
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на языке программирования, использующая цикл с постусловием (repeat... until) для решения ваших задач:
pascalprogram Summation; var number, digitSum, numSum, i: integer; begin // Инициализация суммы цифр и суммы чисел digitSum := 0; numSum := 0; // Задача 1: Проверка суммы цифр натурального числа > 10 repeat writeln('Введите натуральное число (0 - для завершения): '); readln(number); if number > 0 then begin digitSum := 0; i := number; // Вычисление суммы цифр числа repeat digitSum := digitSum + (i mod 10); i := i div 10; until i = 0; // Вывод результата для задачи 1 if digitSum > 10 then writeln('Сумма цифр числа больше 10.') else writeln('Сумма цифр числа меньше или равна 10.'); end; // Задача 2: Сумма чисел больше 30 и меньше 100 if (number > 30) and (number < 100) then numSum := numSum + number; until number = 0; // Вывод суммы чисел из задачи 2 writeln('Сумма чисел больше 30 и меньше 100: ', numSum); end.
Эта программа запрашивает натуральные числа от пользователя (0 для завершения ввода) и выполняет две задачи:
- Проверяет, больше ли сумма цифр введенного натурального числа 10 или нет.
- Суммирует все целые положительные числа, большие 30 и меньшие 100, которые введены пользователем.
Надеюсь, это поможет вам понять, как использовать цикл с постусловием для выполнения указанных задач.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 20
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
