 
Составьте программу, выясняющую, имеются ли в столбцах двухмерного массива А(N,M) повторяющиеся
элементы. Помогите, пожалуста 0
        0
         0
        0
    Ответы на вопрос
 
        ===== PascalABC.NET =====
begin
var (n, m) := ReadInteger2('Укажите n и m:');
var массив := MatrRandom(n, m, -99, 99);
массив.Println;
var Имеются := массив.Cols
.Select(столбец -> столбец.Distinct.Count)
.Any(количество -> количество <> n);
if Имеются then
Print('Имеются')
else
Print('Не имеются')
end.

 0
                    0
                     0
                    0
                 
            Для того чтобы проверить, есть ли повторяющиеся элементы в столбцах двумерного массива A(N, M) на языке программирования Python, вы можете воспользоваться следующим кодом:
pythondef has_duplicate_in_columns(matrix):
    N = len(matrix)
    M = len(matrix[0])
    
    for j in range(M):
        column = [matrix[i][j] for i in range(N)]
        if len(column) != len(set(column)):
            return True
    return False
# Пример использования
A = [
    [1, 2, 3],
    [4, 5, 6],
    [7, 8, 9],
    [1, 2, 3]  # Этот столбец содержит повторяющиеся элементы
]
if has_duplicate_in_columns(A):
    print("В столбцах есть повторяющиеся элементы.")
else:
    print("В столбцах нет повторяющихся элементов.")
Этот код создает функцию has_duplicate_in_columns, которая принимает двумерный массив matrix и проверяет, есть ли в его столбцах повторяющиеся элементы. Если такие элементы найдены, функция возвращает True, в противном случае возвращает False.
Вы можете заменить массив A на свой собственный двумерный массив для проверки наличия повторяющихся элементов в столбцах.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			