Вопрос задан 04.10.2023 в 19:43.
Предмет Информатика.
Спрашивает Рагозина Ксения.
составить программу, запрашивающую числа до тех пор пока не будет введено 10 и посчитывающую
сколько из них нечетных. (подсказка: при проверке нечетности использовать mod) программу можно сделать в паскаль.Ответы на вопрос
Отвечает Журавлёв Артём.
Ответ:
pascal
Объяснение:
var
x, k : integer;
begin
WriteLn('Введите числа (для окончания 10):');
repeat
ReadLn(x);
if x mod 2 = 1 then inc(k);
until x = 10;
WriteLn('Количество нечетных чисел равно ', k);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Pascal, которая запрашивает 10 чисел и подсчитывает, сколько из них нечетных, используя операцию деления по модулю:
pascalprogram CountOddNumbers; var number, count, oddCount: integer; begin count := 0; // Инициализируем счетчик введенных чисел oddCount := 0; // Инициализируем счетчик нечетных чисел writeln('Введите 10 чисел:'); while count < 10 do begin write('Введите число ', count + 1, ': '); readln(number); if number mod 2 <> 0 then oddCount := oddCount + 1; // Если число нечетное, увеличиваем счетчик count := count + 1; // Увеличиваем счетчик введенных чисел end; writeln('Из введенных 10 чисел ', oddCount, ' нечетных.'); end.
Эта программа будет запрашивать 10 чисел и подсчитывать, сколько из них нечетных, а затем выводить результат.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
