Вопрос задан 04.10.2023 в 07:35.
Предмет Информатика.
Спрашивает Смирнова Елизавета.
Паскаль:через составной оператор Begin....end составить программу, которая вычисляет сумму и
среднее арифметическое положительных чисел. ДАЮ 60 БАЛЛОВ СРОЧНООтветы на вопрос
Отвечает Кот Наташа.
Ответ:
Program p1;
Var a, i, n, k,z: integer;
Begin
Write('Введите количество чисел: ');
readln(n);
k:=0;
z:=0;
For i:=1 to n do begin
readln (a);
if (a > 0) then k:=k + a;
z:=z + 1;
end;
Writeln('Сумма положительных чисел = ',k);
Writeln('Среднее арифметическое чисел = ',k/z);
End.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на Pascal, которая вычисляет сумму и среднее арифметическое положительных чисел, введенных пользователем:
pascalprogram CalculateSumAndAverage; var num, sum, count: integer; average: real; begin sum := 0; // Инициализация суммы count := 0; // Инициализация счетчика положительных чисел writeln('Введите положительные числа (для завершения введите отрицательное число):'); repeat write('Введите число: '); readln(num); if num > 0 then begin sum := sum + num; // Добавляем число к сумме count := count + 1; // Увеличиваем счетчик положительных чисел end; until num < 0; if count > 0 then begin average := sum / count; // Вычисляем среднее арифметическое writeln('Сумма положительных чисел: ', sum); writeln('Среднее арифметическое положительных чисел: ', average:0:2); end else writeln('Вы не ввели положительных чисел.'); readln; end.
Эта программа будет запрашивать у пользователя числа до тех пор, пока не будет введено отрицательное число. Затем она вычислит сумму и среднее арифметическое всех положительных чисел и выведет результат на экран.
Похожие вопросы
Информатика 38
Информатика 101
Информатика 166
Информатика 31
Информатика 40
Информатика 78
Информатика 94
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
