Вопрос задан 04.10.2023 в 03:56.
Предмет Информатика.
Спрашивает Самохвалова Полина.
Плиз хелп Составьте программу вычисления в массиве A(15) произведения нечетных элементов. Сделайте
пожалуйста программу на паскалеОтветы на вопрос
Отвечает Щербинина Наталья.
Ответ:
--- PascalABC.NET 3.6.3 ---
begin
var A := ArrRandom(15, -99, 99);
A.Println;
A.Where(p -> p mod 2 <> 0).Product(x -> BigInteger(x)).Println;
end.
Отвечает Елизаров Михаил.
PascalABC.NET
Ответ:
- begin
- ArrRandom(15, -99, 99).Println.Product(x -> x.IsOdd?BigInteger(x):1).Print
- end.
Пример работы:

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на языке Паскаль, которая вычисляет произведение нечетных элементов массива A(15):
pascalprogram CalculateProduct; var A: array[1..15] of Integer; i: Integer; product: Integer; begin product := 1; // Ввод значений в массив A for i := 1 to 15 do begin writeln('Введите элемент A[', i, ']: '); readln(A[i]); end; // Вычисление произведения нечетных элементов for i := 1 to 15 do begin if A[i] mod 2 <> 0 then product := product * A[i]; end; // Вывод результата writeln('Произведение нечетных элементов массива A: ', product); end.
Вы можете скопировать этот код и выполнить его в вашей среде разработки Pascal. Он сначала попросит вас ввести 15 элементов массива, а затем вычислит произведение нечетных элементов и выведет результат.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
