Вопрос задан 04.10.2023 в 02:43. Предмет Информатика. Спрашивает Спаривак Санёк.

PYTHON!!!!!!!!!!!!!!!! На спектакль пускают бесплатно детей до 7 лет, взрослым же нужно покупать

билет. Напишите программу, которая решает кому можно попасть на спектакль. Пример входа №1: Сколько вам лет? : 5 У вас есть билет? : нет Пример результата №1: Можете идти на спектакль Пример входа №2: Сколько вам лет? : 14 У вас есть билет? : нет Пример результата №2: Купите сначала билет
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Закалин Сергей.

Здравствуйте!

///Python 3.8.2

print('Сколько Вам лет?')#Спрашиваем возраст

age=int(input())#Ввод возраста

print('У Вас есть билет?')#Спрашиваем наличие билета

ticket=input()#Ввод наличия билета

if ticket=="Да" or ticket=='да' or age<=7:#Допустить на  лет спектакль можно если ребенку не больше 7 лет или у него есть билет

 print('Можете идти на спектакль') #Если да, пропускаем

else:

 print('Сначала нужно купить билет')#Если нет, то надо купить билет

0 0
Отвечает Кулакова Маргарита.

Код:

age = int(input("Сколько Вам лет? "))

is_had_a_ticket = input("У Вас есть билет? ").lower()

while is_had_a_ticket not in ["да", "нет"]:

   is_had_a_ticket = input("Введите Да или Нет. У Вас есть билет? ").lower()

if age <= 7 or age > 7 and is_had_a_ticket == "да":

   print("Можете идти на спектакль")

else:

   print("Купите сначала билет")




0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете создать программу на Python для решения этой задачи следующим образом:

python
# Запрашиваем возраст пользователя age = int(input("Сколько вам лет? : ")) # Запрашиваем наличие билета has_ticket = input("У вас есть билет? (да/нет) : ").lower() # Проверяем условие и выводим результат if age < 7 or has_ticket == "да": print("Можете идти на спектакль") else: print("Купите сначала билет")

Этот код сначала запрашивает возраст пользователя и проверяет, есть ли у него билет. Затем он проверяет условие: если возраст меньше 7 лет или у пользователя есть билет, программа выводит "Можете идти на спектакль", иначе выводит "Купите сначала билет".

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос