Составьте программу перевода двоичной записи натуральных чисел в десятичную.(В Pascal ABC)
Ответы на вопрос
Var i: integer;
n,k: int64;
s: string;
begin
write('двоичное число: '); readln(s);
k:=1; n:=0;
for i:=length(s) downto 1 do
begin
n:=n+(ord(s[i])-48)*k;
k:=k*2;
end;
writeln('десятичное число: ',n);
end.
Программа перевода двоичной записи натуральных чисел в десятичную на языке Pascal ABC может выглядеть следующим образом:
```pascal program BinaryToDecimal;
var binaryNumber, decimalNumber, remainder, placeValue: integer;
begin writeln('Введите двоичное число: '); readln(binaryNumber);
decimalNumber := 0; placeValue := 1;
while binaryNumber > 0 do begin remainder := binaryNumber mod 10; decimalNumber := decimalNumber + (remainder * placeValue); placeValue := placeValue * 2; binaryNumber := binaryNumber div 10; end;
writeln('Десятичное число: ', decimalNumber); end. ```
Эта программа сначала запрашивает у пользователя ввод двоичного числа. Затем она использует цикл while, чтобы поочередно извлекать цифры из двоичного числа, умножать их на степень двойки соответствующую их позиции и добавлять к результату. После завершения цикла программа выводит полученное десятичное число.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
