Вопрос задан 03.10.2023 в 15:27.
Предмет Информатика.
Спрашивает Карапетян Лианна.
Почему не работает? Напишите программу, которая находит большее число из двух вводимых static
void Main(string[] args) { int a, b, max; Console.WriteLine("Введите первое число:"); a = Convert.ToInt32(Console.ReadLine()); Console.WriteLine("Введите второе число:"); b = Convert.ToInt32(Console.ReadLine()); max = a > b ? a : b; }Ответы на вопрос
Отвечает Левашов Никита.
Объяснение:
она не правильно написана ошибка в первой строке
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Программа, которую вы предоставили, не выводит результат на экран. Для того чтобы увидеть результат, вы должны добавить вывод наибольшего числа на экран. Вот исправленный вариант программы:
csharpusing System;
class Program
{
static void Main(string[] args)
{
int a, b, max;
Console.WriteLine("Введите первое число:");
a = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите второе число:");
b = Convert.ToInt32(Console.ReadLine());
max = a > b ? a : b;
Console.WriteLine("Наибольшее число: " + max);
}
}
В этой версии программы после вычисления наибольшего числа оно выводится на экран с помощью Console.WriteLine, так что вы сможете увидеть результат работы программы.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 35
Информатика 10
Информатика 40
Информатика 22
Информатика 268
Информатика 36
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
