Вопрос задан 02.10.2023 в 15:30. Предмет Информатика. Спрашивает Лукина Даша.

составьте программу, которая в заданном списке, состоящем из положительных и отрицательных чисел

подсчитывает количество отрицательных элементов и выводит результат на экран. то​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кожух Павел.

N = int(input("Сколько элементов будет в списке? "))

a = []

k = 0

for i in range(N):

   a.append(int(input()))

for i in range(N):

   if a[i] < 0:

       k+=1

print(k)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Python, которая подсчитывает количество отрицательных элементов в заданном списке:

python
# Заданный список чисел список_чисел = [5, -2, 9, -7, 3, -1, 0, 4, -6] # Инициализация счетчика отрицательных элементов количество_отрицательных = 0 # Перебор элементов списка и подсчет отрицательных for число in список_чисел: if число < 0: количество_отрицательных += 1 # Вывод результата на экран print("Количество отрицательных элементов в списке:", количество_отрицательных)

Вы можете заменить список_чисел на любой другой список чисел по вашему выбору. Эта программа перебирает каждый элемент списка и, если элемент отрицательный (меньше нуля), увеличивает счетчик количество_отрицательных. По завершении перебора, программа выводит количество отрицательных элементов на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос