ПРОГРАММИРОВАНИЕ (С++) Напишите программу, которая выбирает максимальное и минимальное из трёх
(четырёх, пяти) введённых чисел (не используя max и min)плиз... Ответы на вопрос
Ответ:
C++
Объяснение:
#include <iostream>
using namespace std;
int main()
{
int *arr;
int count;
cout << "Input count numbers: ";
cin >> count;
arr = new int[count];
int maxC = -350000000;
int minC = 350000000;
cout << "Input numbers: " << endl;
for(int i = 0;i < count;i++) {
cin >> arr[i];
}
for(int i = 0;i < count;i++) {
if (arr[i] < minC) {
minC = arr[i];
}
if(maxC < arr[i]) {
maxC = arr[i];
}
}
cout << "Max: " << maxC << " Min: " << minC;
return 0;
}
Конечно, вот пример программы на C++, которая позволяет пользователю ввести три, четыре или пять чисел и находит среди них максимальное и минимальное, не используя функции max и min:
cpp#include <iostream>
int main() {
int n;
std::cout << "Введите количество чисел (от 3 до 5): ";
std::cin >> n;
if (n < 3 || n > 5) {
std::cout << "Некорректное количество чисел. Программа завершена.\n";
return 1;
}
int number;
std::cout << "Введите " << n << " чисел через пробел: ";
std::cin >> number;
int min = number;
int max = number;
for (int i = 1; i < n; ++i) {
std::cin >> number;
if (number < min) {
min = number;
}
if (number > max) {
max = number;
}
}
std::cout << "Минимальное число: " << min << std::endl;
std::cout << "Максимальное число: " << max << std::endl;
return 0;
}
В данной программе сначала запрашивается количество чисел, затем пользователю предлагается ввести соответствующее количество чисел. После ввода программа находит минимальное и максимальное число среди введенных и выводит их на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
