Вопрос задан 01.10.2023 в 00:10.
Предмет Информатика.
Спрашивает Столбов Иван.
Помогите написать программу на с++, пожалуйста: Напишіть програму, щоб перевірити, чи є введене
число додатним, від’ємним або це нуль. Вхідні дані: 7 -5.6 0 Вихідні дані: It is positive number It is a negative number It is ZeroОтветы на вопрос
Отвечает Степаненко Михаил.
Ответ:
#include <iostream>
int main()
{
double number;
std::cin >> number;
if (number > 0)
{
std::cout << "It is positive number" << std::endl;
}
else if (number < 0)
{
std::cout << "It is a negative number" << std::endl;
}
else if (number == 0)
{
std::cout << "It is Zero" << std::endl;
}
return 0;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Звісно, ось програма на C++, яка перевіряє, чи є введене число додатним, від'ємним або це нуль:
cpp#include <iostream>
using namespace std;
int main() {
double number;
// Введення числа в користувача
cout << "Введіть число: ";
cin >> number;
// Перевірка числа і виведення відповідного повідомлення
if (number > 0) {
cout << "Це додатнє число" << endl;
} else if (number < 0) {
cout << "Це від'ємне число" << endl;
} else {
cout << "Це нуль" << endl;
}
return 0;
}
Ця програма зчитує введене користувачем число, а потім перевіряє його значення. Якщо число більше 0, вона виводить "Це додатнє число", якщо число менше 0, вона виводить "Це від'ємне число", інакше виводить "Це нуль".
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
