Напишите программу (в тетради) рассчитывающую количество цветов (Y), подаренных на 8 марта девочкам
(X) и остаток. Используйте операторы div и mod. X,Y вводите с клавиатуры.Ответы на вопрос
program tsveti;
var x,y,z,w:integer;
begin
write('Введите количество девочек: '); readln(x);
write('Введите количество цветов: '); readln(y);
if (y div x) mod 2 = 0 then begin // здесь мы проверяем, не получается ли чётное количество цветков, и если получается чётное, то вычитаем остаток и количество девочек, чтобы добиться нечётного количества
w := y mod x + x;
z := (y - w) div x;
end
else begin
w := y mod x;
z := y div x;
end;
writeln('Девочкам подарили по ', z, ' шт. цветков.');
writeln('Осталось ', w, ' шт. цветков.');
end.
Конечно, вот пример программы на Python, которая рассчитывает количество цветов (Y), подаренных на 8 марта девочкам (X), и остаток, используя операторы div и mod:
python# Вводим количество подаренных цветов (X) с клавиатуры
X = int(input("Введите количество подаренных цветов: "))
# Задаем количество цветов в одном букете (например, 8)
цветов_в_букете = 8
# Рассчитываем количество букетов (Y) и остаток
Y = X // цветов_в_букете # Целочисленное деление (div)
остаток = X % цветов_в_букете # Остаток от деления (mod)
# Выводим результаты
print(f"На 8 марта девочкам подарили {Y} букетов цветов и осталось {остаток} цветов.")
Вы можете скопировать этот код в тетрадь и запустить его, чтобы рассчитать количество букетов цветов (Y) и остаток после подарка на 8 марта.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
