Вопрос задан 29.09.2023 в 08:07. Предмет Информатика. Спрашивает Камалетдинова Алина.

Написать программу в C# по типу игры где есть варианты ответа и от них будет зависеть конец,

используя Console.WriteLine, if, Console.ReadLine например: вы оказались в незнакомом вам месте ваши действия а-бежать, b-кричать)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Назаров Артем.

Ответ:

using System;

namespace games_znaniga

{

   class Program

   {

       static void Main(string[] args)

       {

           int x = 0;

           while (x == 0)

           {

               Random rnd = new Random();

               Console.WriteLine("\nПривет! Давай сыграем в 'камень-ножницы-бумага'!\nНажми любую клавишу, чтобы начать!");

               Console.ReadKey(); Console.WriteLine("\nСледуй командам ниже! Значения вводи с клавиатуры без ошибок!\n\nЕсли хочешь выбрать ножницы - введи '1' и нажми 'Enter'" +

                   "!\nЕсли хочешь выбрать камень - введи '2' и нажми 'Enter'!\nЕсли хочешь выбрать бумагу - введи '3' и нажми 'Enter'!\n");

               string a = Console.ReadLine();

               if ((a != "1") && (a != "2") && (a != "3"))

               {

                   Console.WriteLine("Ты ошибся при вводе =(\nНажми любую клавишу, чтобы начать игру заново!\n");

                   Console.ReadKey();

                   continue;

               }

               int b = rnd.Next(1, 4);

               int n = Convert.ToInt32(a);

               if (n == b)

               {

                   Console.WriteLine("\nНичья! Компьютер выбрал то же, что и ты =)");

               }

               if ((n == 1) && (b == 2))

               {

                   Console.WriteLine("\nТы проиграл! Компьютер выбрал камень и размозжил в щепки твои ножницы!");

               }

               if ((n == 1) && (b == 3))

               {

                   Console.WriteLine("\nТы выиграл! Компьютер выбрал бумагу! Ты порезал его на части!");

               }

               if ((n == 2) && (b == 1))

               {

                   Console.WriteLine("\nТы выиграл! Компьютер выбрал ножницы! Твой камень размозжил их в щепки!");

               }

               if ((n == 2) && (b == 3))

               {

                   Console.WriteLine("\nТы проиграл! Компьютер выбрал бумагу, в которую обернул твой камень!");

               }

               if ((n == 3) && (b == 1))

               {

                   Console.WriteLine("\nТы проиграл! Компьютер выбрал ножницы, он разрезал твою бумагу!");

               }

               if ((n == 3) && (b == 2))

               {

                   Console.WriteLine("\nТы выиграл! Компьютер выбрал камень, ты завернул его в бумагу!");

               }

               Console.WriteLine("\nНажми '1', если хочешь начать игру заново!\nИначе нажми любую клавишу, чтобы закончить игру!\n");

               string d = Console.ReadLine();

               if (d != "1")

               {

                   Console.WriteLine("Игра завершена!\nЗакрой это окно нажатием любой клавиши!");

                   x += 1;

               }

           }

           

       }

   }

}

Пояснение:

Игра "камень-ножницы-бумага" на С#.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на C#, реализующей игру с вариантами ответа и зависящим от них концом:

csharp
using System; class Program { static void Main(string[] args) { Console.WriteLine("Вы оказались в незнакомом вам месте."); Console.WriteLine("Ваши действия:"); Console.WriteLine("a - бежать"); Console.WriteLine("b - кричать"); string choice = Console.ReadLine(); if (choice.ToLower() == "a") { Console.WriteLine("Вы побежали, но оказались в тупике."); Console.WriteLine("Конец игры, вы проиграли."); } else if (choice.ToLower() == "b") { Console.WriteLine("Вы закричали и прогнали незнакомца."); Console.WriteLine("Конец игры, вы победили!"); } else { Console.WriteLine("Некорректный выбор. Игра окончена."); } } }

В этой программе игроку предлагается сделать выбор, введя "a" или "b", и в зависимости от выбора выводится соответствующее сообщение о результате этого выбора.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос