Вопрос задан 29.09.2023 в 04:47. Предмет Информатика. Спрашивает Кофанова Алёна.

Напишите программу, которая читает слово из консоли и выводит его назад. Порядок входных данных:

str - строка длиной от 0 до 1000. Вывод: То же слово, что прочитала ваша программа. Ограничения: Память 128 Mib Время 1,0 секунд Процессоры 1.0 Java
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ковешникова Юлия.

import java.util.Scanner;

public class Main {

public static void main(String[] args) {

Scanner k = new Scanner(System.in);

String str = k.next();

System.out.println(str);

}

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для чтения слова из консоли и вывода его назад в Java, вы можете использовать следующую программу:

java
import java.util.Scanner; public class ReverseWord { public static void main(String[] args) { Scanner scanner = new Scanner(System.in); // Читаем строку из консоли System.out.print("Введите слово: "); String inputWord = scanner.next(); // Выводим слово задом наперед String reversedWord = reverseString(inputWord); System.out.println("Обратно: " + reversedWord); scanner.close(); } // Функция для обращения строки public static String reverseString(String str) { StringBuilder reversed = new StringBuilder(); for (int i = str.length() - 1; i >= 0; i--) { reversed.append(str.charAt(i)); } return reversed.toString(); } }

Эта программа сначала считывает слово из консоли, а затем использует функцию reverseString для его обращения. Обратное слово выводится на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос