 
Вопрос задан 28.09.2023 в 22:07.
Предмет Информатика.
Спрашивает Егоров Данила.
JAVA☕️ Напишите программу, которая создает массив, элементами которого являются все двузначные
целые положительные числа, где и цифра единиц, и цифра десятков делятся без остатка на три. Программа должна поменять местами ближайшие парные и непарные по индексу элементы массива, то есть нулевой элемент меняется с первым, второй элемент меняется с третьим, четвертый с пятым и так далее. Входные данные: Входящих данных нет. Выходные данные: Первая строка содержит первичный создан массив, вторая строка - массив с переставленными элементами. пример: вывод: 30 33 36 39 60 63 66 69 90 93 96 99 33 30 39 36 63 60 69 66 93 90 99 96 Большое спасибо!) 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Здоровцова Дианочка.
                
    Відповідь:
public static void main(String[] args) {
int[]a={30,33,36,39,60,63,66,69,90,93,96,99};
for(int i=0;i<a.length-1;i+=2){
a[i]+=a[i+1];
a[i+1]=a[i]-a[i+1];
a[i]-=a[i+1];}
for(int t:a){
System.out.print(t+" ");}}
Но будьте предельно аккуратны - такой трюк мы может творить только в том случае,если это числа(для чисел с плавающей точкой будут некоторые потери). В другом случае используйте функции обмена.
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Конечно! Вот Java-код, который реализует вашу задачу:
javapublic class Main {
    public static void main(String[] args) {
        int[] originalArray = generateArray();
        int[] modifiedArray = swapPairs(originalArray);
        
        // Вывод первоначального массива
        for (int num : originalArray) {
            System.out.print(num + " ");
        }
        System.out.println();
        
        // Вывод модифицированного массива
        for (int num : modifiedArray) {
            System.out.print(num + " ");
        }
    }
    // Метод для генерации массива
    public static int[] generateArray() {
        int[] array = new int[10];
        int index = 0;
        for (int i = 10; i <= 99; i++) {
            if (i % 3 == 0 && i % 10 % 3 == 0) {
                array[index] = i;
                index++;
            }
        }
        return array;
    }
    // Метод для перестановки пар элементов
    public static int[] swapPairs(int[] array) {
        for (int i = 0; i < array.length - 1; i += 2) {
            int temp = array[i];
            array[i] = array[i + 1];
            array[i + 1] = temp;
        }
        return array;
    }
}
Этот код создает массив из всех двузначных положительных чисел, где и цифры десятков, и цифры единиц делятся на три. Затем он меняет местами ближайшие парные и непарные элементы по индексу.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			