Языки программирования С++ Программа вводит натуральное n, затем вводит вещественные числа в
соответствии с этим количеством. Найти сумму тех чисел, порядковый номер которых кратен 3Ответы на вопрос
Відповідь:
#include<iostream>
#include<locale>
#include<conio.h>
bool Summa(){
int N;
long double Suma=0,t;
setlocale(0,"");
std::cout<<"Введите N:\n";
std::cin>>N;
if(N<=0){
std::cout<<"\nНеверный ввод количества, повторите ввод.";
std::cin.clear();//очистка состояния потока ввода
std::cin.ignore(100000000,'\n');//очистка потока
return true;
}
else{
for(int d=1;d<=N;d++){
std::cout<<"Введите "<<d<<"-ое число:\n";
std::cin>>t;
if(d%3==0) Suma+=t;
}
std::cout<<"Сумма = "<<Suma;
return false;
}
}
int main(){
while(true){
if(!Summa()) break;}
std::cout<<"\nСпасибо! Для закрытия нажмите любую клавишу.";
getch();//задержка консоли
return 0;}
Вы можете написать программу на C++, которая выполняет данную задачу. Вот пример такой программы:
cpp#include <iostream>
int main() {
int n;
std::cout << "Введите натуральное число n: ";
std::cin >> n;
if (n <= 0) {
std::cout << "Число n должно быть натуральным." << std::endl;
return 1;
}
double number, sum = 0;
for (int i = 1; i <= n; ++i) {
std::cout << "Введите вещественное число #" << i << ": ";
std::cin >> number;
if (i % 3 == 0) {
sum += number;
}
}
std::cout << "Сумма чисел с порядковыми номерами, кратными 3: " << sum << std::endl;
return 0;
}
Эта программа сначала запрашивает у пользователя натуральное число n, затем запрашивает n вещественных чисел и вычисляет сумму только тех чисел, порядковый номер которых кратен 3.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
