Вопрос задан 28.09.2023 в 05:50.
Предмет Информатика.
Спрашивает Матула Олександр.
В паскале написать программу.Если первая (слева) цифра нечетная то вывести 1 ,если четная то
вывести 2.Помогите пожалуйста.Даю 10бОтветы на вопрос
Отвечает Намсараева Аяна.
uses math;
var
a: integer;
begin
readln(a);
a := abs(a);
while a >= 10 do
a := a div 10;
if (a mod 2 = 0) then
writeln(2)
else
writeln(1);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на языке Pascal, которая выполняет описанное вами действие:
pascalprogram CheckFirstDigit; var number, firstDigit: integer; begin // Вводим число с клавиатуры write('Введите число: '); readln(number); // Получаем первую цифру числа firstDigit := abs(number); // Берем модуль числа, чтобы обеспечить положительное значение while firstDigit >= 10 do firstDigit := firstDigit div 10; // Удаляем последние цифры, оставляем только первую // Проверяем, является ли первая цифра числа четной или нечетной if firstDigit mod 2 = 1 then writeln('Первая цифра нечетная: 1') else writeln('Первая цифра четная: 2'); end.
Эта программа запрашивает у пользователя ввод числа, а затем находит первую цифру этого числа и определяет, является ли она четной или нечетной. Результат выводится на экран. Если первая цифра нечетная, программа выведет "1", если четная - "2".
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 23
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
