Вопрос задан 28.09.2023 в 02:24.
Предмет Информатика.
Спрашивает Шеина Вика.
Напишите программу, которая сгенерирует число кратное 5 в диапазоне от 10 до 50 на C++
Ответы на вопрос
Отвечает Карась Андрей.
#include <iostream>
#include <random>
#include <ctime>
int main() {
std::srand(std::time(0));
std::cout << 10 + 5 * (std::rand() % 9);
}
Отвечает Авдеева Анастасия.
---------------------------

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на C++, которая генерирует случайное число, кратное 5, в диапазоне от 10 до 50:
cpp#include <iostream>
#include <cstdlib>
#include <ctime>
int main() {
// Инициализируем генератор случайных чисел текущим временем
std::srand(static_cast<unsigned int>(std::time(nullptr)));
int randomNumber;
do {
// Генерируем случайное число в диапазоне от 10 до 50
randomNumber = 10 + std::rand() % 41;
} while (randomNumber % 5 != 0); // Повторяем генерацию, пока число не будет кратным 5
std::cout << "Случайное число, кратное 5, в диапазоне от 10 до 50: " << randomNumber << std::endl;
return 0;
}
Эта программа использует функции std::rand() и std::time(nullptr) для генерации случайного числа и инициализации генератора случайных чисел. Затем она генерирует случайное число в диапазоне от 10 до 50 и проверяет, кратно ли оно 5. Если нет, она повторяет генерацию, пока не получит число, кратное 5.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
