Составить программу, вычисляющую сумму всех положительных элементов массива а[5][5] и произведение
отрицательных С++ Без функции.Ответы на вопрос
Відповідь:
#include <iostream>
#include <cstdlib>
#include <time.h>
using namespace std;
const int n = 5, m = 5;
int main(){
srand(time(NULL));
setlocale(LC_ALL, "Rus");
int sum = 0, pr = 1;
int **arr = new int *[n];
for (int i = 0; i < n; i++)
arr[i]=new int[m];
cout << "Матрица порядка " << n << "x" << m << ":" << endl;
for(int i = 0; i < n; i++){
for(int j = 0; j < m; j++){
arr[i][j] = rand() % 109 + (-37);
}
}
for(int i = 0; i < n; i++){
for(int j = 0; j < m; j++){
cout << arr[i][j] << "\t";
}
cout << endl;
}
for(int i = 0; i < n; i++){
for(int j = 0; j < m; j++){
if(arr[i][j] > 0){
sum+= arr[i][j];
}
if(arr[i][j] < 0){
pr *= arr[i][j];
}
}
}
cout << "\nСумма положительных елементов массива = " << sum << endl;
cout << "Произведение отрицательных елементов массива = " << pr << endl;
for (int i = 0; i < n; i++)
delete[]arr[i];
delete[]arr;
return 0;
}
Конечно, вот программа на C++, которая вычисляет сумму всех положительных элементов массива a[5][5] и произведение отрицательных элементов без использования функций:
cpp#include <iostream>
int main() {
int a[5][5] = {
{1, -2, 3, -4, 5},
{-6, 7, -8, 9, -10},
{11, -12, 13, -14, 15},
{-16, 17, -18, 19, -20},
{21, -22, 23, -24, 25}
};
int sumPositive = 0;
int productNegative = 1;
for (int i = 0; i < 5; ++i) {
for (int j = 0; j < 5; ++j) {
if (a[i][j] > 0) {
sumPositive += a[i][j];
} else if (a[i][j] < 0) {
productNegative *= a[i][j];
}
}
}
std::cout << "Сумма положительных элементов: " << sumPositive << std::endl;
std::cout << "Произведение отрицательных элементов: " << productNegative << std::endl;
return 0;
}
Эта программа создает двумерный массив a[5][5], проходит по всем его элементам и вычисляет сумму положительных элементов и произведение отрицательных элементов. Результат выводится на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
