Вопрос задан 27.09.2023 в 05:35. Предмет Информатика. Спрашивает Недобой Дмитрий.

Написать программу "Инвертирование массива". Дан массив D из 10 целых чисел, заданных случайным

образом из промежутка [5; 20]. Выводить на экран монитора данный массив и инвертированный массив. ПРИМЕР. Исходный массив D: 6 8 10 12 8 12 15 11 5 7 Конечный массив D: 7 5 11 15 12 8 12 10 8 6 дам 35 баллов!!!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Смурага Саша.

Ответ:

import random

D=[]

for i in range(0,10):

   D.append(random.randint(5,20))

print(D)

print(D[::-1])

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Python для инвертирования массива:

python
import random # Создаем исходный массив D из 10 случайных целых чисел в диапазоне [5, 20] D = [random.randint(5, 20) for _ in range(10)] # Выводим исходный массив на экран print("Исходный массив D:", D) # Инвертируем массив D D_inverted = D[::-1] # Выводим инвертированный массив на экран print("Конечный массив D:", D_inverted)

Эта программа создает массив D из 10 случайных целых чисел в диапазоне от 5 до 20 с помощью функции random.randint(). Затем она выводит исходный массив D на экран и инвертирует его, используя срез D[::-1]. Инвертированный массив D_inverted также выводится на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос