Вопрос задан 27.09.2023 в 00:13. Предмет Информатика. Спрашивает Майдич Євген.

ПАСКАЛЬ Написать программу для вычисления математического выраженияb=(x-y)*u4и еще.Написать

программу с циклом если а+b>c то c=b*a иначе c=b:aПомогите пожалуйста СРОЧНО дам 44б
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Субочев Даня.

1)

var

 x,y,u,b:real;

begin

 write('Введите x,y,u: '); readln(x,y,u);

 //

 b:=(x-y)*u*4;

 writeln('Если (x-y)*u*4:',b);

 //

 b:=(x-y)*power(u,4);

 writeln('Если (x-y)*u^4:',b);

end.

//Выбери нужный тебе блок по условию

2)

var

 a,b,c:real;

begin

 write('Введите a,b,c: '); readln(a,b,c);

 repeat

   if a+b>c then

     begin

       c:=b*a;

       writeln('True. c: ',c);

     end

       else

         begin

           c:=b/a;

           writeln('False. c: ',c);

         end;

 until a>a;

end.

Если моё решение вам помогло, отметьте его как лучшее. Спасибо! Удачи!

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Pascal, которая вычисляет выражение b = (x - y) * u4 и затем сравнивает a + b с c, выполняя соответствующее действие:

pascal
program CalculateExpression; var x, y, u4, a, b, c: real; begin { Ввод значений x, y и u4 } write('Введите значение x: '); readln(x); write('Введите значение y: '); readln(y); write('Введите значение u4: '); readln(u4); { Вычисление b } b := (x - y) * u4; { Ввод значения a } write('Введите значение a: '); readln(a); { Ввод значения c } write('Введите значение c: '); readln(c); { Проверка условия и выполнение соответствующего действия } if a + b > c then c := b * a else c := b / a; { Вывод результата } writeln('Результат: c = ', c); readln; end.

Вы можете скопировать этот код в среду разработки Pascal и выполнить его, введя необходимые значения. Программа вычислит b и затем в зависимости от условия выполнит одну из операций над c.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос