Вопрос задан 26.09.2023 в 20:43.
Предмет Информатика.
Спрашивает Линдеманн Тиль.
Составить программу в паскале Даны три числа. Возвести в квадрат те из них, значения которых не
отрицательны, а в третью степень отрицательныеОтветы на вопрос
Отвечает Парук Соня.
var
a, b, c: Int64;
begin
Write('a = ');
Read(a);
Write('b = ');
Read(b);
Write('c = ');
Read(c);
if (a >= 0) then
WriteLn(a * a)
else
WriteLn(a * a * a);
if (b >= 0) then
WriteLn(b * b)
else
WriteLn(b * b * b);
if (c >= 0) then
WriteLn(c * c)
else
WriteLn(c * c * c);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на Pascal, которая выполняет указанные действия:
pascalprogram SquaresAndCubes; var num1, num2, num3: real; begin writeln('Введите три числа: '); readln(num1, num2, num3); if num1 >= 0 then writeln('Квадрат первого числа: ', num1 * num1) else writeln('Третья степень первого числа: ', num1 * num1 * num1); if num2 >= 0 then writeln('Квадрат второго числа: ', num2 * num2) else writeln('Третья степень второго числа: ', num2 * num2 * num2); if num3 >= 0 then writeln('Квадрат третьего числа: ', num3 * num3) else writeln('Третья степень третьего числа: ', num3 * num3 * num3); readln; end.
Эта программа сначала запрашивает у пользователя три числа, а затем проверяет каждое из них на неотрицательность. Если число неотрицательное, оно возводится в квадрат, иначе в третью степень, и результаты выводятся на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
