Вопрос задан 26.09.2023 в 09:22.
Предмет Информатика.
Спрашивает Федоренко Данило.
(По желанию)Написать программу на языке Pascal для решения одной задачи на выбор:- на
отметку "4" Организовать горизонтальный числовой ряд 1 2 3 4 5 ….10; - на отметку "5" Найти сумму ряда S = 15+16+17+...+n. Сразу две надо даю 50 баллов я.п паскаль а не питонОтветы на вопрос
Отвечает Яковлева Евгения.
Ответ:
2 задача:
var i,n,s:integer;
begin
read(n);
s:=0;
for i:=15 to n do begin
s+=i;
end;
print(s);
end.
1 задача:
var i:integer;
begin
for i:=1 to 10 do begin
print(i);
end;
end.
Объяснение:
нужны пояснения - скажи
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программы на языке Pascal для решения обеих задач:
- Горизонтальный числовой ряд от 1 до 10:
pascalprogram HorizontalNumberSeries; var i: integer; begin for i := 1 to 10 do write(i, ' '); writeln; end.
- Нахождение суммы ряда S = 15+16+17+...+n:
pascalprogram SumOfSeries; var n, i, sum: integer; begin write('Введите значение n: '); readln(n); sum := 0; for i := 15 to n do sum := sum + i; writeln('Сумма ряда S = ', sum); end.
Вы можете скомпилировать и запустить эти программы на своем компьютере, чтобы получить результаты.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 33
Информатика 32
Информатика 51
Информатика 95
Информатика 36
Информатика 23
Информатика 36
Информатика 12
Информатика 14
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
