Вопрос задан 26.09.2023 в 02:01. Предмет Информатика. Спрашивает Стромов Алексей.

ПИТОН, ПЖ ПОМОГИТЕ 50 баллов отдаю!!! Условие Дано число N - количество учеников в группе М200.

Далее вводится N строк в формате: Фамилия И.О. Ваша задача - вывести на экран сообщение "В группе М200 Питон изучают:", а затем в столбик в алфавитном порядке распечатать только фамилии учеников группы. Формат входных данных Дано число N - количество учеников в группе М200. Далее вводится N строк в формате: Фамилия И.О. Формат выходных данных Фраза: "В группе М200 Питон изучают:", а затем фамилии в столбик по алфавиту. входные данные 4 Яблочкин В.А. Бобров Д.С. Мамонтов А.В. Зебрикова О.А. В группе М200 Питон изучают: Бобров Зебрикова Мамонтов Яблочкин выходные данные 5 Мирошина С.У. Дубовинов В.Е. Кабачкова П.Е. Фонарь М.Д. Рожков Ш.А. В группе М200 Питон изучают: Дубовинов Кабачкова Мирошина Рожков Фонарь
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Гусев Лёша.

Ответ:

n=int(input())

print("В группе М200 Питон изучают:")

a=[]

for j in range(n):

   x=input()

   x=x[:-5]

   a.append(x)

a.sort()

for elem in a:

   print(elem)

Объяснение:

решение

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я помогу вам написать код на Python для выполнения данной задачи. Вот код:

python
# Считываем количество учеников N = int(input()) # Создаем список для хранения фамилий фамилии = [] # Считываем фамилии и добавляем их в список for i in range(N): строка = input() # Разбиваем строку на слова (фамилию и инициалы) слова = строка.split() # Берем первое слово, которое будет фамилией, и добавляем его в список фамилия = слова[0] фамилии.append(фамилия) # Сортируем фамилии в алфавитном порядке фамилии.sort() # Выводим фразу print("В группе М200 Питон изучают:") # Выводим фамилии по одной в столбик for фамилия in фамилии: print(фамилия)

Вы можете вставить этот код в среду разработки Python и запустить его, чтобы выполнить задачу. Он сначала считывает количество учеников, затем считывает фамилии и инициалы каждого ученика, извлекает фамилию и добавляет ее в список, затем сортирует список фамилий и выводит их в алфавитном порядке.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос