Вопрос задан 25.09.2023 в 22:24. Предмет Информатика. Спрашивает Слюзкова Вероника.

Нужно написать программу на языке java: a) Создайте объект класса String, например, “I like

Java!!!”. б) Распечатать последний символ строки. в) Проверить, заканчивается ли ваша строка подстрокой “!!!”. г) Проверить, начинается ли ваша строка подстрокой “I like”. д) Проверить, содержит ли ваша строка подстроку “Java”. e) Найти позицию подстроки “Java” в строке “I like Java!!!”. ж) Заменить все символы “а” на “о”. з) Преобразуйте строку к верхнему регистру. и) Преобразуйте строку к нижнему регистру.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Протас Полина.

Объяснение:

Напишите метод, который принимает в качестве параметра любую строку, например “I like Java!!!”. Распечатать последний символ строки. Используем метод String.charAt().Проверить, заканчивается ли ваша строка подстрокой “!!!”. Используем метод String.endsWith().Проверить, начинается ли ваша строка подстрокой “I like”. Используем метод String.startsWith().Проверить, содержит ли ваша строка подстроку “Java”. Используем метод String.contains().Найти позицию подстроки “Java” в строке “I like Java!!!”.Заменить все символы “а” на “о”. Преобразуйте строку к верхнему регистру.Преобразуйте строку к нижнему регистру.Вырезать строку Java c помощью метода String.substring().

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот Java-программа, выполняющая все указанные вами действия:

java
public class StringManipulation { public static void main(String[] args) { // a) Создайте объект класса String String originalString = "I like Java!!!"; // б) Распечатать последний символ строки char lastChar = originalString.charAt(originalString.length() - 1); System.out.println("Последний символ строки: " + lastChar); // в) Проверить, заканчивается ли строка подстрокой "!!!" boolean endsWithExclamation = originalString.endsWith("!!!"); System.out.println("Строка заканчивается на '!!!': " + endsWithExclamation); // г) Проверить, начинается ли строка подстрокой "I like" boolean startsWithILike = originalString.startsWith("I like"); System.out.println("Строка начинается с 'I like': " + startsWithILike); // д) Проверить, содержит ли строка подстроку "Java" boolean containsJava = originalString.contains("Java"); System.out.println("Строка содержит 'Java': " + containsJava); // e) Найти позицию подстроки "Java" в строке int javaIndex = originalString.indexOf("Java"); System.out.println("Позиция подстроки 'Java': " + javaIndex); // ж) Заменить все символы 'а' на 'о' String replacedString = originalString.replace('a', 'o'); System.out.println("Строка после замены: " + replacedString); // з) Преобразуйте строку к верхнему регистру String upperCaseString = originalString.toUpperCase(); System.out.println("Строка в верхнем регистре: " + upperCaseString); // и) Преобразуйте строку к нижнему регистру String lowerCaseString = originalString.toLowerCase(); System.out.println("Строка в нижнем регистре: " + lowerCaseString); } }

Этот код создает строку "I like Java!!!", а затем выполняет указанные вами операции. Результаты каждой операции выводятся на консоль.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос