Язык C++: Напишите программу, которая запрашивает три целых числа (от -10000 до 10000) и
выстраивает их по неубыванию. Sample Input 1: 5 2 3 Sample Output 1: 2 3 5 Sample Input 2: 4 8 4 Sample Output 2: 4 4 8Ответы на вопрос
#include <iostream>
#include <algorithm>
int main() {
int a, b, c;
std::cin >> a >> b >> c;
int arr[] = {a, b, c};
int size = sizeof(arr) / sizeof(arr[0]);
std::sort(arr, arr + size);
for (int i = 0; i < size; i++) {
std::cout << arr[i] << " ";
}
return 0;
}
Ответ:
#include <iostream>
#include <algorithm>
int main() {
int a, b, c;
std::cin >> a >> b >> c;
// Массив для хранения трех чисел
int numbers[3] = {a, b, c};
// Сортировка чисел по неубыванию
std::sort(numbers, numbers + 3);
// Вывод отсортированных чисел
for (int i = 0; i < 3; i++) {
std::cout << numbers[i] << " ";
}
return 0;
}
Объяснение:
Вы можете скопировать этот код в среду разработки C++ (например, Code::Blocks, Visual Studio или онлайн-компилятор) и выполнить программу. После запуска программа будет запрашивать три целых числа и выводить их в отсортированном порядке по неубыванию.
Вы можете написать программу на C++, чтобы выполнить задачу следующим образом:
cpp#include <iostream>
int main() {
int a, b, c;
// Запрашиваем три целых числа
std::cout << "Введите три целых числа: ";
std::cin >> a >> b >> c;
// Сортируем числа по неубыванию с помощью временной переменной
if (a > b) {
int temp = a;
a = b;
b = temp;
}
if (b > c) {
int temp = b;
b = c;
c = temp;
}
if (a > b) {
int temp = a;
a = b;
b = temp;
}
// Выводим числа в порядке неубывания
std::cout << "Числа в порядке неубывания: " << a << " " << b << " " << c << std::endl;
return 0;
}
Эта программа сначала запрашивает три целых числа, затем использует временные переменные для сортировки чисел по неубыванию и выводит результат.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
