Вопрос задан 18.09.2023 в 10:51.
Предмет Информатика.
Спрашивает Петрина Макс.
ПАСКАЛЬ АБС! СРОЧНО! ПОМОГИТЕ ПОЖАЛУЙСТА! 1. напишите программу формирования массива размером 5*5
с помощью датчика случайных чисел. Замените в нем нечетные значения элементов максимальным. Выведите на экран исходный и измененный массивы.2. Составьте программу формирования и вывода на печать одномерного массива, состоящего из максимальных элементов строк двумерного массива, заданного с помомщью датчика случайных чиселОтветы на вопрос
Отвечает Филимонова Аня.
1)
var a:array [1..5,1..5] of integer;
i,j,max:integer;
begin
randomize;
for i:=1 to 5 do
begin
for j:=1 to 5 do
begin
a[i,j]:=random(9)+1;
write (a[i,j]:2);
end;
writeln;
end;
max:=a[1,1];
for i:=1 to 5 do
for j:=1 to 5 do
if a[i,j]>max then max:=a[i,j];
writeln;
for i:=1 to 5 do
begin
for j:=1 to 5 do
begin
if a[i,j] mod 2 = 1 then a[i,j]:=max;
write (a[i,j]:2);
end;
writeln;
end;
end.
2)
var a1:array [1..5,1..5] of integer;
a2:array [1..5] of integer;
i,j,k,max:integer;
begin
randomize;
for i:=1 to 5 do
begin
for j:=1 to 5 do
begin
a1[i,j]:=random(9)+1;
write (a1[i,j]:2);
end;
writeln;
max:=a1[i,1];
for k:=2 to 5 do
if a1[i,k]>max then max:=a1[i,k];
a2[i]:=max;
end;
writeln;
for i:=1 to 5 do write (a2[i]:2);
end.
var a:array [1..5,1..5] of integer;
i,j,max:integer;
begin
randomize;
for i:=1 to 5 do
begin
for j:=1 to 5 do
begin
a[i,j]:=random(9)+1;
write (a[i,j]:2);
end;
writeln;
end;
max:=a[1,1];
for i:=1 to 5 do
for j:=1 to 5 do
if a[i,j]>max then max:=a[i,j];
writeln;
for i:=1 to 5 do
begin
for j:=1 to 5 do
begin
if a[i,j] mod 2 = 1 then a[i,j]:=max;
write (a[i,j]:2);
end;
writeln;
end;
end.
2)
var a1:array [1..5,1..5] of integer;
a2:array [1..5] of integer;
i,j,k,max:integer;
begin
randomize;
for i:=1 to 5 do
begin
for j:=1 to 5 do
begin
a1[i,j]:=random(9)+1;
write (a1[i,j]:2);
end;
writeln;
max:=a1[i,1];
for k:=2 to 5 do
if a1[i,k]>max then max:=a1[i,k];
a2[i]:=max;
end;
writeln;
for i:=1 to 5 do write (a2[i]:2);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программы на языке Pascal для выполнения ваших задач:
- Программа для формирования и изменения двумерного массива:
pascalprogram MaxArray; const N = 5; // Размер массива (5x5) var A: array[1..N, 1..N] of integer; i, j, maxElement: integer; procedure FillArray; begin for i := 1 to N do for j := 1 to N do A[i, j] := Random(100); // Заполняем массив случайными числами от 0 до 99 end; procedure ReplaceOddWithMax; begin maxElement := -1; for i := 1 to N do for j := 1 to N do if (A[i, j] mod 2 = 1) and (A[i, j] > maxElement) then maxElement := A[i, j]; for i := 1 to N do for j := 1 to N do if A[i, j] mod 2 = 1 then A[i, j] := maxElement; end; procedure PrintArray; begin for i := 1 to N do begin for j := 1 to N do Write(A[i, j]:4); Writeln; end; end; begin Randomize; FillArray; Writeln('Исходный массив:'); PrintArray; ReplaceOddWithMax; Writeln('Измененный массив:'); PrintArray; end.
- Программа для формирования и вывода одномерного массива из максимальных элементов строк:
pascalprogram MaxElementsInRows; const N = 5; // Размер массива (5x5) var A: array[1..N, 1..N] of integer; B: array[1..N] of integer; i, j: integer; procedure FillArray; begin for i := 1 to N do for j := 1 to N do A[i, j] := Random(100); // Заполняем массив случайными числами от 0 до 99 end; procedure FindMaxInRows; begin for i := 1 to N do begin B[i] := A[i, 1]; // Предполагаем, что максимум в строке находится в первом элементе for j := 2 to N do if A[i, j] > B[i] then B[i] := A[i, j]; // Нашли больший элемент в строке end; end; procedure PrintArray; begin for i := 1 to N do Write(B[i]:4); Writeln; end; begin Randomize; FillArray; Writeln('Двумерный массив:'); for i := 1 to N do begin for j := 1 to N do Write(A[i, j]:4); Writeln; end; FindMaxInRows; Writeln('Одномерный массив из максимальных элементов строк:'); PrintArray; end.
Обратите внимание, что в обеих программах используется процедура Randomize, чтобы инициализировать генератор случайных чисел. Вам также может потребоваться настроить диапазон случайных чисел и размер массива в соответствии с вашими требованиями.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
