Вопрос задан 17.09.2023 в 18:29.
Предмет Информатика.
Спрашивает Вечер Антон.
Помогите составить программу решения задачи в паскале АВС.
Дано вещественное число - цена 1 кг конфет. Вывести стоимость 0.1,0.2...,1кг конфетОтветы на вопрос
Отвечает Хуторская Анастасия.
Var C, i: real;
begin
readln(C);
i := 0.1;
while (i <= 1) do
begin
writeln(C * i);
i := i + 0.1;
end;
end.
Уже решал, но теперь по-другому)
begin
readln(C);
i := 0.1;
while (i <= 1) do
begin
writeln(C * i);
i := i + 0.1;
end;
end.
Уже решал, но теперь по-другому)
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на языке Pascal, которая решает вашу задачу:
pascalprogram CalculateCandyCost; var pricePerKg, weight, totalCost: real; i: integer; begin // Вводим цену за 1 кг конфет write('Введите цену за 1 кг конфет: '); readln(pricePerKg); // Используем цикл для подсчета стоимости for i := 1 to 10 do begin weight := i * 0.1; // определяем вес в кг totalCost := pricePerKg * weight; // рассчитываем стоимость // Выводим результат writeln('Стоимость ', weight:0:1, ' кг конфет: ', totalCost:0:2, ' руб.'); end; readln; end.
Программа запрашивает у пользователя цену за 1 кг конфет, а затем с использованием цикла for вычисляет стоимость 0.1, 0.2, ..., 1 кг конфет и выводит результат на экран.
Например, если вам нужно посчитать стоимость конфет с ценой 100 рублей за 1 кг, то вы вводите 100, и программа выведет:
Стоимость 0.1 кг конфет: 10.00 руб. Стоимость 0.2 кг конфет: 20.00 руб. Стоимость 0.3 кг конфет: 30.00 руб. Стоимость 0.4 кг конфет: 40.00 руб. Стоимость 0.5 кг конфет: 50.00 руб. Стоимость 0.6 кг конфет: 60.00 руб. Стоимость 0.7 кг конфет: 70.00 руб. Стоимость 0.8 кг конфет: 80.00 руб. Стоимость 0.9 кг конфет: 90.00 руб. Стоимость 1.0 кг конфет: 100.00 руб.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 11
Информатика 1255
Информатика 115
Информатика 1220
Информатика 11
Информатика 10
Информатика 66
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
