Вопрос задан 12.09.2023 в 15:14.
Предмет Информатика.
Спрашивает Севостьянова Павлина.
Дан целочисленный массив в размере 20 элементов. Составить программу на Паскале. Посчитать кол-во
элементов кратных трём. B{1.....20}Ответы на вопрос
Отвечает Шелевиля Стас.
Const n=20;
var
a:array [1..n] of integer;
i,k:integer;
begin
k:=0;
for i:=1 to n do begin
readln(a[i]);
if a[i] mod 3=0 then
k:=k+1;
end;
writeln(k);
end.
var
a:array [1..n] of integer;
i,k:integer;
begin
k:=0;
for i:=1 to n do begin
readln(a[i]);
if a[i] mod 3=0 then
k:=k+1;
end;
writeln(k);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на Паскале, которая считает количество элементов в целочисленном массиве, кратных трём:
pascalprogram CountMultiplesOfThree; var B: array[1..20] of integer; i, count: integer; begin { Инициализируем массив B случайными значениями } randomize; for i := 1 to 20 do B[i] := random(100); { Здесь предполагается, что значения в массиве B случайны и варьируются от 0 до 99 } { Инициализируем счетчик нулевым значением } count := 0; { Считаем количество элементов кратных трём } for i := 1 to 20 do begin if B[i] mod 3 = 0 then count := count + 1; end; { Выводим результат на экран } writeln('Количество элементов кратных трём в массиве B: ', count); readln; end.
Эта программа создает массив B с 20 случайными целыми числами от 0 до 99, затем перебирает элементы массива и увеличивает счетчик (count) каждый раз, когда элемент кратен трём. В конце программа выводит количество таких элементов на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 437
Информатика 11
Информатика 10
Информатика 43
Информатика 22
Информатика 42
Информатика 63
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
