Вопрос задан 12.09.2023 в 08:40.
Предмет Информатика.
Спрашивает Манджиев Данил.
Составить программу на паскаль.
Слова могут содержать любые символы языка. Найти и вывести в самом длинномслове все символы, отличные от заглавных латинских букв. Использовать множества.Ответы на вопрос
Отвечает Гаврилова Ирина.
var
a : array of string;
str, m: string;
begin
readln(str);
a := str.Split(' ');
foreach str in a do
if (m.Length < str.Length) then
m := str;
foreach kchr: char in m do
if not (kchr in ['A'..'Z']) then
write(kchr);
end.
a : array of string;
str, m: string;
begin
readln(str);
a := str.Split(' ');
foreach str in a do
if (m.Length < str.Length) then
m := str;
foreach kchr: char in m do
if not (kchr in ['A'..'Z']) then
write(kchr);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот программа на Pascal, которая находит и выводит все символы, отличные от заглавных латинских букв, из самого длинного слова во введенной строке, используя множества:
pascalprogram LongestWord; uses SysUtils; var inputString, longestWord: string; words: TStringList; i: integer; nonCapitalLetters: set of char; begin nonCapitalLetters := ['a'..'z', '0'..'9', ' ', '.', ',', '!', '?', ';', ':', '-', '_']; // Добавьте сюда другие символы, которые вы хотите исключить writeln('Введите строку:'); readln(inputString); words := TStringList.Create; words.Delimiter := ' '; words.DelimitedText := inputString; longestWord := ''; for i := 0 to words.Count - 1 do begin if Length(words[i]) > Length(longestWord) then longestWord := words[i]; end; writeln('Самое длинное слово: ', longestWord); writeln('Символы, отличные от заглавных латинских букв:'); for i := 1 to Length(longestWord) do begin if not (longestWord[i] in ['A'..'Z']) and not (longestWord[i] in nonCapitalLetters) then write(longestWord[i]); end; writeln; words.Free; readln; end.
Вы можете ввести строку, и программа найдет самое длинное слово и выведет все символы из него, которые не являются заглавными латинскими буквами.
Похожие вопросы
Информатика 13
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
