Вопрос задан 07.09.2023 в 12:40.
Предмет Информатика.
Спрашивает Смирнова Дарья.
Написать программу, в которой массив генерируется случайными числами от -10 до 5. c++
Ответы на вопрос
Отвечает Топовский Денис.
#include <iostream>
#include <time.h>
using namespace std;
int main()
{
srand(time(NULL));
int mas[1000];
int n;
cin>>n;
for(int i=0;i<n;i++)
{
mas[i]=(rand()%16)-10;//генерация массива
cout<<mas[i]<<" ";//вывод массива
}
return 0;
}
#include <time.h>
using namespace std;
int main()
{
srand(time(NULL));
int mas[1000];
int n;
cin>>n;
for(int i=0;i<n;i++)
{
mas[i]=(rand()%16)-10;//генерация массива
cout<<mas[i]<<" ";//вывод массива
}
return 0;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для создания программы на C++, которая генерирует массив случайных чисел от -10 до 5, вам потребуется использовать библиотеку <iostream> для ввода/вывода данных и <cstdlib> для генерации случайных чисел. Вот пример такой программы:
cpp#include <iostream>
#include <cstdlib>
#include <ctime>
int main() {
// Устанавливаем seed для генератора случайных чисел на основе текущего времени
std::srand(static_cast<unsigned int>(std::time(nullptr)));
const int arraySize = 10; // Размер массива
int randomArray[arraySize];
// Заполняем массив случайными числами от -10 до 5
for (int i = 0; i < arraySize; ++i) {
randomArray[i] = std::rand() % 16 - 10; // Генерируем числа от -10 до 5
}
// Выводим сгенерированный массив
std::cout << "Случайный массив от -10 до 5: ";
for (int i = 0; i < arraySize; ++i) {
std::cout << randomArray[i] << " ";
}
std::cout << std::endl;
return 0;
}
В этой программе мы сначала устанавливаем seed для генератора случайных чисел на основе текущего времени, чтобы обеспечить разнообразие генерируемых чисел при каждом запуске программы. Затем мы создаем массив randomArray заданного размера и заполняем его случайными числами от -10 до 5 с помощью оператора % для ограничения диапазона значений. Наконец, мы выводим сгенерированный массив на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
