Вопрос задан 07.09.2023 в 02:55.
Предмет Информатика.
Спрашивает Константинопольский Альберт.
Составить программу в Паскаль:Даны 4 числа,выделить целые части и найти среднее арифметическое этих
чисел.Ответы на вопрос
Отвечает Соловьёва Елена.
Var
i:integer;
a,c:real;
begin
c:=0;
Writeln('Введите четыре произвольных числа');
for i:=1 to 4 do
begin
Read(a); c:=c+Int(a)
end;
c:=c/4;
Writeln('Среднее арифметическое равно ',c)
end.
Тестовое решение:
Введите четыре произвольных числа
4.7 5.03 4.12 5
Среднее арифметическое равно 4.5
i:integer;
a,c:real;
begin
c:=0;
Writeln('Введите четыре произвольных числа');
for i:=1 to 4 do
begin
Read(a); c:=c+Int(a)
end;
c:=c/4;
Writeln('Среднее арифметическое равно ',c)
end.
Тестовое решение:
Введите четыре произвольных числа
4.7 5.03 4.12 5
Среднее арифметическое равно 4.5
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на Pascal, которая выполняет задачу:
pascalprogram CalculateAverage; var num1, num2, num3, num4: real; // объявляем переменные для ввода чисел integerPart1, integerPart2, integerPart3, integerPart4: integer; // объявляем переменные для целых частей average: real; // объявляем переменную для среднего арифметического begin // Вводим 4 числа write('Введите первое число: '); readln(num1); write('Введите второе число: '); readln(num2); write('Введите третье число: '); readln(num3); write('Введите четвертое число: '); readln(num4); // Выделяем целые части чисел integerPart1 := trunc(num1); integerPart2 := trunc(num2); integerPart3 := trunc(num3); integerPart4 := trunc(num4); // Вычисляем среднее арифметическое целых частей average := (integerPart1 + integerPart2 + integerPart3 + integerPart4) / 4; // Выводим результат writeln('Среднее арифметическое целых частей чисел: ', average); end.
Вы можете скопировать этот код в среду программирования Pascal и выполнить его, чтобы найти среднее арифметическое целых частей введенных чисел.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
