Вопрос задан 03.09.2023 в 12:13.
Предмет Информатика.
Спрашивает Шматков Данил.
Составить программу на паскале. Дано натуральное число: а) Найти количество четных цифр; б) Верно
ли, что цифра а встречается в числе более двух раз а вводится с клавиатуры.Ответы на вопрос
Отвечает Кучинський Ярик.
Var a,b,c,c1,a1:integer;
begin
write('введите число => ');
readln(a);
write('введите число а => ');
readln(a1);
c:=0;
c1:=0;
while (a<>0) do begin
b:=a mod 10;
a:=a div 10;
if (b mod 2 =0) then c:=c+1;
if (b=a1) then c1:=c1+1;
end;
writeln('количество чётных цифр =>', c);
if (c1>2) then writeln('а встречается в числе больше двух раз');
end.
begin
write('введите число => ');
readln(a);
write('введите число а => ');
readln(a1);
c:=0;
c1:=0;
while (a<>0) do begin
b:=a mod 10;
a:=a div 10;
if (b mod 2 =0) then c:=c+1;
if (b=a1) then c1:=c1+1;
end;
writeln('количество чётных цифр =>', c);
if (c1>2) then writeln('а встречается в числе больше двух раз');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на Pascal, которая решает задачу:
pascalprogram CountEvenDigitsAndCheckRepetition; var number, a, digit, evenCount, repetitionCount: integer; isRepetition: boolean; begin // Ввод натурального числа с клавиатуры writeln('Введите натуральное число: '); readln(number); // Ввод цифры a с клавиатуры writeln('Введите цифру a: '); readln(a); // Инициализация счетчиков evenCount := 0; repetitionCount := 0; isRepetition := false; // Проверяем каждую цифру числа while number > 0 do begin digit := number mod 10; // Получаем последнюю цифру числа // а) Подсчет четных цифр if digit mod 2 = 0 then evenCount := evenCount + 1; // б) Проверка на повторение цифры a if digit = a then repetitionCount := repetitionCount + 1; // Если цифра a встретилась более двух раз, выходим из цикла if repetitionCount > 2 then begin isRepetition := true; break; end; number := number div 10; // Убираем последнюю цифру числа end; // Вывод результатов writeln('Количество четных цифр в числе: ', evenCount); if isRepetition then writeln('Цифра ', a, ' встречается более двух раз в числе.') else writeln('Цифра ', a, ' не встречается более двух раз в числе.'); readln; end.
Эта программа сначала запрашивает у пользователя натуральное число и цифру a. Затем она подсчитывает количество четных цифр в числе и проверяет, встречается ли цифра a более двух раз. Результаты выводятся на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 35
Информатика 10
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
