
Вопрос задан 02.09.2023 в 19:59.
Предмет Информатика.
Спрашивает Шевченко Аэлита.
Помогите составить задачу в Pascal С клавиатуры вводят строку. Составить программу, которая: a)
определит количество символов в ней; b) выведет на экран первый, второй и последний символы; c) выведет на экран коды первого и последнего символов строки; ∗ d) проверит, не совпадают ли первый и последний символы строки; ∗ e) определит количество символов в строке чётно или нечётно; ∗ f) проверит, есть ли в ней (в строке) слово «мама».

Ответы на вопрос

Отвечает Юдина Алина.
// PascalABC.Net 3.0, сборка 1064
var
s:string;
n:integer;
begin
Write('Введите строку: '); Readln(s);
// a
n:=Length(s);
Writeln('Количество символов в строке равно ',n);
// b
Writeln(s[1],', ',s[2],', ',s[n]);
// c
Writeln(Ord(s[1]),', ',Ord(s[n]));
// d
if s[1]=s[n] then Writeln('Первый и последний символы совпадают')
else Writeln('Первый и последний символы не совпадают');
// e
if n mod 2 = 0 then Writeln('Количество символов в строке четно')
else Writeln('Количество символов в строке нечетно');
// f
if Pos('мама',s)>0 then Writeln('Строка содержит слово "мама"')
else Writeln('Строка не содержит слово "мама"')
end.
Тестовое решение:
Введите строку: Тестовая строка со словом <мама> внутри
Количество символов в строке равно 39
Т, е, и
210, 232
Первый и последний символы не совпадают
Количество символов в строке нечетно
Строка содержит слово "мама"
var
s:string;
n:integer;
begin
Write('Введите строку: '); Readln(s);
// a
n:=Length(s);
Writeln('Количество символов в строке равно ',n);
// b
Writeln(s[1],', ',s[2],', ',s[n]);
// c
Writeln(Ord(s[1]),', ',Ord(s[n]));
// d
if s[1]=s[n] then Writeln('Первый и последний символы совпадают')
else Writeln('Первый и последний символы не совпадают');
// e
if n mod 2 = 0 then Writeln('Количество символов в строке четно')
else Writeln('Количество символов в строке нечетно');
// f
if Pos('мама',s)>0 then Writeln('Строка содержит слово "мама"')
else Writeln('Строка не содержит слово "мама"')
end.
Тестовое решение:
Введите строку: Тестовая строка со словом <мама> внутри
Количество символов в строке равно 39
Т, е, и
210, 232
Первый и последний символы не совпадают
Количество символов в строке нечетно
Строка содержит слово "мама"



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на Pascal, которая выполняет все указанные вами задачи:
pascalprogram StringOperations; var inputString: string; lengthOfString, firstCharCode, lastCharCode: integer; firstChar, lastChar: char; begin // Ввод строки с клавиатуры writeln('Введите строку:'); readln(inputString); // a) Определить количество символов в строке lengthOfString := length(inputString); writeln('Количество символов в строке: ', lengthOfString); // b) Вывести первый, второй и последний символы firstChar := inputString[1]; lastChar := inputString[lengthOfString]; writeln('Первый символ: ', firstChar); if lengthOfString >= 2 then writeln('Второй символ: ', inputString[2]); writeln('Последний символ: ', lastChar); // c) Вывести коды первого и последнего символов строки firstCharCode := ord(firstChar); lastCharCode := ord(lastChar); writeln('Код первого символа: ', firstCharCode); writeln('Код последнего символа: ', lastCharCode); // d) Проверить, не совпадают ли первый и последний символы строки if firstChar <> lastChar then writeln('Первый и последний символы строки не совпадают.') else writeln('Первый и последний символы строки совпадают.'); // e) Определить, количество символов в строке четно или нечетно if lengthOfString mod 2 = 0 then writeln('Количество символов в строке четное.') else writeln('Количество символов в строке нечетное.'); // f) Проверить, есть ли в строке слово "мама" if Pos('мама', inputString) > 0 then writeln('В строке есть слово "мама".') else writeln('В строке нет слова "мама".'); readln; end.
Эта программа выполняет все задачи, которые вы описали, и выводит соответствующие результаты.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili