Вопрос задан 28.08.2023 в 15:05.
Предмет Информатика.
Спрашивает Куюмчян Эдгар.
ПАСКАЛЬ!!. Известно, что первые два элемента массива равны a и b. А каждый следующий элемент
равен сумме значений всех предыдущих элементов и собственного номера (нумерация элементов массива начинается с единицы). Заполните массив из n элементов, используя этот принцип и выведите значения элементов массива в обратном порядке. Формат входных данных Целые положительное число n (2 Целые числа a,b (-50 < a,b < 50) Формат выходных данных Строка, содержащая элементы искомого массива в обратном порядке, записанные через пробелОтветы на вопрос
Отвечает Единов Влад.
Const n=10;
var ar:array[1..n] of integer;
a,b,i,s:integer;
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
ar[1]:=a; ar[2]:=b; s:=a+b;
for i:=3 to n do
begin
ar[i]:=s+i;
s:=s+ar[i];
end;
for i:=1 to n do write(ar[i],' ');
writeln;
end.
Пример:
a = 2
b = 3
2 3 8 17 35 71 143 287 575 1151
var ar:array[1..n] of integer;
a,b,i,s:integer;
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
ar[1]:=a; ar[2]:=b; s:=a+b;
for i:=3 to n do
begin
ar[i]:=s+i;
s:=s+ar[i];
end;
for i:=1 to n do write(ar[i],' ');
writeln;
end.
Пример:
a = 2
b = 3
2 3 8 17 35 71 143 287 575 1151
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи на языке программирования Pascal можно использовать следующий код:
pascalprogram ReverseArray; var n, a, b, i: integer; arr: array of integer; begin // Вводим значения n, a и b readln(n, a, b); // Инициализируем длину массива и выделяем память под него SetLength(arr, n); // Заполняем массив согласно условиям задачи arr[0] := a; arr[1] := b; for i := 2 to n - 1 do arr[i] := (i + 1) + Sum(arr, i); // Выводим элементы массива в обратном порядке for i := n - 1 downto 0 do begin write(arr[i]); if i > 0 then write(' '); end; writeln; end.
В этом коде мы сначала вводим значения n, a и b. Затем создаем массив arr и заполняем его согласно условиям задачи. Наконец, мы выводим элементы массива arr в обратном порядке, разделяя их пробелами.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
