Вопрос задан 27.08.2023 в 10:47.
Предмет Информатика.
Спрашивает Ажібаева Молдир.
Составьте программу, Дано количество информации в битах. Вывести в удобной форме в более крупных
единицах. (до Мб). Пример вывода: 10240 бит = 1280 байт = 1,25 Кб = 0,0012 МбОтветы на вопрос
Отвечает Смирнов Евгений.
Var
n:integer;
begin
read(n);
write(n,' бит = ', n/8, ' байт = ', n/8192:0:2,' Кб = ',n/(8*sqr(1024)):0:4,' Мб');
end.
Альтернативное решение:
var
n: integer;
b, kb, mb: real;
begin
read(n);
b := n / 8;
kb := b / 1024;
mb := kb / 1024;
write(n, ' бит = ', b:0, ' байт = ', kb:0:2, ' Кб = ', mb:0:4, ' Мб');
end.
n:integer;
begin
read(n);
write(n,' бит = ', n/8, ' байт = ', n/8192:0:2,' Кб = ',n/(8*sqr(1024)):0:4,' Мб');
end.
Альтернативное решение:
var
n: integer;
b, kb, mb: real;
begin
read(n);
b := n / 8;
kb := b / 1024;
mb := kb / 1024;
write(n, ' бит = ', b:0, ' байт = ', kb:0:2, ' Кб = ', mb:0:4, ' Мб');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на Python, которая преобразует количество информации из битов в более крупные единицы (байты, килобайты, мегабайты):
python# Получаем количество информации в битах от пользователя
bits = int(input("Введите количество информации в битах: "))
# Преобразуем в байты
bytes = bits / 8
# Преобразуем в килобайты
kilobytes = bytes / 1024
# Преобразуем в мегабайты
megabytes = kilobytes / 1024
# Выводим результаты
print(f"{bits} бит = {bytes} байт = {kilobytes:.2f} Кб = {megabytes:.4f} Мб")
Просто введите количество информации в битах, и программа выведет его в более крупных единицах до мегабайтов, как в вашем примере.
Похожие вопросы
Информатика 134
Информатика 44
Информатика 26
Информатика 25
Информатика 164
Информатика 78
Информатика 94
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
