Вопрос задан 19.08.2023 в 21:04.
Предмет Информатика.
Спрашивает Джабраилов Раджи.
Помогите!!!Нужно написать программы на Pascal + блок-схемы. С клавиатуры последовательно вводится
n-целых чисел: 1)Сколько чисел отличаются от первого на величину а? 2)Для всех чисел,кроме 1 и последнего ,определите ,сколько из них больше своих соседей?(слева и справа) 3)Вывести числа ,которые делятся на 3 ,но не делятся на 5.Ответы на вопрос
Отвечает Каминская Диана.
Const
n = 13;
Var
a,i,C,k:integer;
M:array[1..N] of integer;
Begin
k:=0;
Write('a = ');
ReadLn(a);
WriteLn('Введите целые числа');
For i:= 1 to n do
Read(M[i]);
For i:= 2 to n do
if M[i]-a = M[1] then k:=k+1;
WriteLn('1: k = ',k);
k:=0;
For i:= 2 to n-1 do
if (M[i-1]<M[i])and(M[i]>M[i+1]) then k:=k+1;
WriteLn('2: k = ',k);
Write('3: ');
For i:= 1 to n do
if (M[i] mod 3 = 0)and(M[i] mod 5 <> 0) then Write(M[i],' ')
End.
n = 13;
Var
a,i,C,k:integer;
M:array[1..N] of integer;
Begin
k:=0;
Write('a = ');
ReadLn(a);
WriteLn('Введите целые числа');
For i:= 1 to n do
Read(M[i]);
For i:= 2 to n do
if M[i]-a = M[1] then k:=k+1;
WriteLn('1: k = ',k);
k:=0;
For i:= 2 to n-1 do
if (M[i-1]<M[i])and(M[i]>M[i+1]) then k:=k+1;
WriteLn('2: k = ',k);
Write('3: ');
For i:= 1 to n do
if (M[i] mod 3 = 0)and(M[i] mod 5 <> 0) then Write(M[i],' ')
End.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам с этим! Вот программа на Pascal, которая выполняет указанные действия:
pascalprogram Main; var n, a, i, diffCount, greaterNeighborCount, num: integer; begin writeln('Введите количество чисел (n): '); readln(n); writeln('Введите величину (a): '); readln(a); diffCount := 0; greaterNeighborCount := 0; writeln('Введите ', n, ' целых чисел:'); for i := 1 to n do begin readln(num); // Задача 1 if abs(num - num[1]) = a then diffCount := diffCount + 1; // Задача 2 if (i > 1) and (i < n) then begin if (num > num[i - 1]) and (num > num[i + 1]) then greaterNeighborCount := greaterNeighborCount + 1; end; // Задача 3 if (num mod 3 = 0) and (num mod 5 <> 0) then writeln('Число, делящееся на 3, но не делящееся на 5: ', num); end; writeln('Количество чисел, отличающихся от первого на ', a, ': ', diffCount); writeln('Количество чисел, больших своих соседей: ', greaterNeighborCount); end.
Этот код сначала запрашивает количество чисел n и величину a. Затем он последовательно вводит n целых чисел и выполняет указанные операции для каждого числа. После ввода всех чисел, программа выводит результаты для каждой из трех задач.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 30
Информатика 25
Информатика 101
Информатика 14
Информатика 501
Информатика 52
Информатика 42
Информатика 238
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
