Вопрос задан 06.08.2023 в 15:49.
Предмет Информатика.
Спрашивает Козиренко Снежана.
Написать программу, которая задает пользователю вопрос о том, какую фигуру тот выбирает:
прямоугольник, или треугольник. После того, как пользователь выберет фигуру, программа интересуется, что он хочет найти для данной фигуры: площадь или периметр. После того, как пользователь выберет величину, которую хочет посчитать, программа запрашивает данные для подсчета величины данной фигуры. на С++Ответы на вопрос
Отвечает Забываев Антон.
#include <iostream>
using namespace std;
int main()
{
int n, k, a, b, c, h;
setlocale(LC_ALL, "rus");
cout << "Выберите фигуру \n";
cout << "1 - Треугольник \n";
cout << "2 - Прямоугольник \n";
cin >> n;
cout << "Площадь или периметр \n";
cout << "1 - Площадь \n";
cout << "2 - Периметр \n";
cin >> k;
if (n == 1) {
if (k == 1) {
cout << "Введите длину основания: ";
cin >> b;
cout << "Введите высоту: ";
cin >> h;
cout << "S = " << b * h * 0.5 << '\n';
}
if (k == 2) {
cout << "Введите 3 стороны:" << '\n' << "a: ";
cin >> a;
cout << '\n';
cout << "b:";
cin >> b;
cout << "/nc: ";
cin >> c;
cout << "P = " << a + b + c << '\n';
}
}
if (n == 2) {
if (k == 1) {
cout << "Введите длину: ";
cin >> a;
cout << "Введите ширину: ";
cin >> b;
cout << "S = " << a * b << '\n';
}
if (k == 2) {
cout << "Введите длину";
cin >> a;
cout << "Введите ширину: ";
cin >> b;
cout << "P = " << 2 * (a + b) << '\n';
}
}
}
using namespace std;
int main()
{
int n, k, a, b, c, h;
setlocale(LC_ALL, "rus");
cout << "Выберите фигуру \n";
cout << "1 - Треугольник \n";
cout << "2 - Прямоугольник \n";
cin >> n;
cout << "Площадь или периметр \n";
cout << "1 - Площадь \n";
cout << "2 - Периметр \n";
cin >> k;
if (n == 1) {
if (k == 1) {
cout << "Введите длину основания: ";
cin >> b;
cout << "Введите высоту: ";
cin >> h;
cout << "S = " << b * h * 0.5 << '\n';
}
if (k == 2) {
cout << "Введите 3 стороны:" << '\n' << "a: ";
cin >> a;
cout << '\n';
cout << "b:";
cin >> b;
cout << "/nc: ";
cin >> c;
cout << "P = " << a + b + c << '\n';
}
}
if (n == 2) {
if (k == 1) {
cout << "Введите длину: ";
cin >> a;
cout << "Введите ширину: ";
cin >> b;
cout << "S = " << a * b << '\n';
}
if (k == 2) {
cout << "Введите длину";
cin >> a;
cout << "Введите ширину: ";
cin >> b;
cout << "P = " << 2 * (a + b) << '\n';
}
}
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на C++, которая реализует описанное вами поведение:
cpp#include <iostream>
#include <cmath>
int main() {
std::cout << "Выберите фигуру: 1 - прямоугольник, 2 - треугольник: ";
int choice;
std::cin >> choice;
if (choice == 1) { // Прямоугольник
std::cout << "Выбран прямоугольник.\n";
std::cout << "Что вы хотите найти? 1 - площадь, 2 - периметр: ";
int rectangleChoice;
std::cin >> rectangleChoice;
if (rectangleChoice == 1) { // Площадь прямоугольника
double width, height;
std::cout << "Введите ширину прямоугольника: ";
std::cin >> width;
std::cout << "Введите высоту прямоугольника: ";
std::cin >> height;
double area = width * height;
std::cout << "Площадь прямоугольника: " << area << std::endl;
} else if (rectangleChoice == 2) { // Периметр прямоугольника
double width, height;
std::cout << "Введите ширину прямоугольника: ";
std::cin >> width;
std::cout << "Введите высоту прямоугольника: ";
std::cin >> height;
double perimeter = 2 * (width + height);
std::cout << "Периметр прямоугольника: " << perimeter << std::endl;
} else {
std::cout << "Неверный выбор." << std::endl;
}
} else if (choice == 2) { // Треугольник
std::cout << "Выбран треугольник.\n";
std::cout << "Что вы хотите найти? 1 - площадь, 2 - периметр: ";
int triangleChoice;
std::cin >> triangleChoice;
if (triangleChoice == 1) { // Площадь треугольника
double base, height;
std::cout << "Введите основание треугольника: ";
std::cin >> base;
std::cout << "Введите высоту треугольника: ";
std::cin >> height;
double area = 0.5 * base * height;
std::cout << "Площадь треугольника: " << area << std::endl;
} else if (triangleChoice == 2) { // Периметр треугольника
double side1, side2, side3;
std::cout << "Введите длину первой стороны треугольника: ";
std::cin >> side1;
std::cout << "Введите длину второй стороны треугольника: ";
std::cin >> side2;
std::cout << "Введите длину третьей стороны треугольника: ";
std::cin >> side3;
double perimeter = side1 + side2 + side3;
std::cout << "Периметр треугольника: " << perimeter << std::endl;
} else {
std::cout << "Неверный выбор." << std::endl;
}
} else {
std::cout << "Неверный выбор." << std::endl;
}
return 0;
}
Пример выше позволяет пользователю выбрать фигуру (прямоугольник или треугольник), затем выбрать, что нужно вычислить (площадь или периметр), и вводить соответствующие данные для вычисления.
Похожие вопросы
Информатика 81
Информатика 98
Информатика 16
Информатика 34
Информатика 91
Информатика 354
Информатика 31
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
