Вопрос задан 01.08.2023 в 08:15.
Предмет Информатика.
Спрашивает Ширяев Даниил.
Помогите с задачей С# - Ввести одномерный массив из элементов. Все элементы, которые не кратны 4 и
стоят в первой половине массива уменьшить на 10. Массив вывести до и после преобразования.Ответы на вопрос
Отвечает Маратовна Улжан.
static void Main(string[] args)
{
int[] A = new int[10];
Random rand = new Random();
Console.WriteLine("До: ");
for (int i = 0; i < A.Length; i++)
{
A[i] = rand.Next(-20,20);
Console.Write("{0} ", A[i]);
}
Console.WriteLine();
Console.WriteLine("После: ");
for (int i = 0; i < A.Length; i++)
{
if ((A[i] % 4 != 0) && (i < A.Length / 2))
A[i] = A[i] - 10;
Console.Write("{0} ", A[i]);
}
Console.ReadKey();
}
{
int[] A = new int[10];
Random rand = new Random();
Console.WriteLine("До: ");
for (int i = 0; i < A.Length; i++)
{
A[i] = rand.Next(-20,20);
Console.Write("{0} ", A[i]);
}
Console.WriteLine();
Console.WriteLine("После: ");
for (int i = 0; i < A.Length; i++)
{
if ((A[i] % 4 != 0) && (i < A.Length / 2))
A[i] = A[i] - 10;
Console.Write("{0} ", A[i]);
}
Console.ReadKey();
}

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения данной задачи вам потребуется написать программу на языке C#. Вот пример кода, который решает задачу:
csharpusing System;
class Program
{
static void Main()
{
Console.Write("Введите размер массива: ");
int n = int.Parse(Console.ReadLine());
int[] arr = new int[n];
// Ввод элементов массива
for (int i = 0; i < n; i++)
{
Console.Write($"Введите элемент {i + 1}: ");
arr[i] = int.Parse(Console.ReadLine());
}
Console.WriteLine("Массив до преобразования:");
PrintArray(arr);
// Преобразование массива
for (int i = 0; i < n / 2; i++)
{
if (arr[i] % 4 != 0)
{
arr[i] -= 10;
}
}
Console.WriteLine("Массив после преобразования:");
PrintArray(arr);
}
static void PrintArray(int[] arr)
{
foreach (int element in arr)
{
Console.Write(element + " ");
}
Console.WriteLine();
}
}
Как работает код:
- Сначала пользователю предлагается ввести размер массива
n. - Затем создается массив
arrуказанного размера. - Пользователю предлагается ввести элементы массива с помощью цикла
for. - Массив выводится на экран перед преобразованием с помощью функции
PrintArray. - Цикл
forпробегает по первой половине массива и проверяет, кратен ли элемент 4. Если элемент не кратен 4, то он уменьшается на 10. - Измененный массив снова выводится на экран после преобразования с помощью функции
PrintArray.
Таким образом, в результате выполнения программы, вы увидите массив до и после преобразования.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
