Вопрос задан 01.08.2023 в 07:26.
Предмет Информатика.
Спрашивает Занозовский Максим.
Программисты помогите! надо написать программу на паскале, найти произведение отрицательных
элементов массива.Ответы на вопрос
Отвечает Зотова Соня.
Program n1;
var a: array[1..10] of integer;
i,p: integer;
begin
randomize;
write('массив: ');
p:=1;
for i:=1 to 10 do
begin
a[i]:=random(21)-10;
write(a[i],' ');
if a[i]<0 then p:=p*a[i];
end;
writeln;
write('произведение отрицательных: ',p)
end.
var a: array[1..10] of integer;
i,p: integer;
begin
randomize;
write('массив: ');
p:=1;
for i:=1 to 10 do
begin
a[i]:=random(21)-10;
write(a[i],' ');
if a[i]<0 then p:=p*a[i];
end;
writeln;
write('произведение отрицательных: ',p)
end.
Отвечает Соломатина Елена.
PascalABC.NET 3.3.5, сборка 1650 от 01.04.2018
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
a.Where(t->t<0).Aggregate(BigInteger(1),(p,q)->p*q).Println
end.
Пример
n= 15
-44 -33 -7 48 14 44 -14 -14 -45 -13 16 47 -48 19 -14
-783151649280
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
a.Where(t->t<0).Aggregate(BigInteger(1),(p,q)->p*q).Println
end.
Пример
n= 15
-44 -33 -7 48 14 44 -14 -14 -45 -13 16 47 -48 19 -14
-783151649280
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам написать программу на Pascal для нахождения произведения отрицательных элементов массива. Вот пример программы:
pascalprogram ProizvedenieOtricatelnykh; const N = 10; // Размер массива var arr: array[1..N] of integer; i: integer; proizvedenie: integer; begin // Вводим элементы массива writeln('Введите ', N, ' элементов массива:'); for i := 1 to N do readln(arr[i]); // Инициализируем произведение отрицательных элементов единицей proizvedenie := 1; // Находим произведение отрицательных элементов for i := 1 to N do begin if arr[i] < 0 then proizvedenie := proizvedenie * arr[i]; end; // Выводим результат writeln('Произведение отрицательных элементов массива: ', proizvedenie); readln; end.
Программа создает массив arr размером N, заполняет его значениями, а затем находит произведение отрицательных элементов и выводит результат. Убедитесь, что вводите все 10 элементов массива, чтобы программа правильно работала. Если вам нужен массив другого размера, замените значение константы N на желаемый размер.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
