Вопрос задан 01.08.2023 в 05:01.
Предмет Информатика.
Спрашивает Ткаченко Ваня.
Написать в C++ программу: Ввести массив. Найти произведение положительных элементов массива,
стоящих после максимального элемента массива.Ответы на вопрос
Отвечает Горохова Диана.
// Compiler: G++ + Bionic
#include <iostream>
#include <cstdlib>
int main()
{
int max, ptr, num = 1;
int n; scanf("%d",&n);
int *m = new int[n];
for(int i = 0; i < n; i++){
scanf("%d",&m[i]),
max = (!i?m[0],ptr=0:(max<m[i]?m[i],ptr=i:max));
if(i+1==n)
for(int j = i; j >= ptr; j--)
num *= (m[j]>0?m[j]:1);
}
delete [] m;
printf("%d",num);
return EXIT_SUCCESS;
}
#include <iostream>
#include <cstdlib>
int main()
{
int max, ptr, num = 1;
int n; scanf("%d",&n);
int *m = new int[n];
for(int i = 0; i < n; i++){
scanf("%d",&m[i]),
max = (!i?m[0],ptr=0:(max<m[i]?m[i],ptr=i:max));
if(i+1==n)
for(int j = i; j >= ptr; j--)
num *= (m[j]>0?m[j]:1);
}
delete [] m;
printf("%d",num);
return EXIT_SUCCESS;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи вам потребуется написать программу на C++, которая позволит пользователю ввести массив, а затем найдет произведение положительных элементов, стоящих после максимального элемента массива. Вот пример такой программы:
cpp#include <iostream>
#include <vector>
int main() {
// Запросим у пользователя размер массива
int size;
std::cout << "Введите размер массива: ";
std::cin >> size;
// Создадим массив с заданным пользователем размером
std::vector<int> array(size);
// Заполним массив
std::cout << "Введите элементы массива:\n";
for (int i = 0; i < size; ++i) {
std::cin >> array[i];
}
// Найдем максимальный элемент и его позицию в массиве
int maxElement = array[0];
int maxIndex = 0;
for (int i = 1; i < size; ++i) {
if (array[i] > maxElement) {
maxElement = array[i];
maxIndex = i;
}
}
// Найдем произведение положительных элементов, стоящих после максимального элемента
int product = 1;
for (int i = maxIndex + 1; i < size; ++i) {
if (array[i] > 0) {
product *= array[i];
}
}
// Выведем результат
std::cout << "Максимальный элемент: " << maxElement << std::endl;
std::cout << "Произведение положительных элементов, стоящих после максимального: " << product << std::endl;
return 0;
}
Скопируйте код в среду разработки C++ (например, Code::Blocks, Visual Studio, или другую), скомпилируйте и запустите программу. После запуска она запросит размер массива и элементы, а затем выведет максимальный элемент и произведение положительных элементов, стоящих после него.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
