Вопрос задан 01.08.2023 в 03:48.
Предмет Информатика.
Спрашивает Дергунов Дмитрий.
Паскаль!!! СРОЧНО!!! Написать программу вывода на экран положительных чисел массива, кратных
числу 5.Ответы на вопрос
Отвечает Клуб Марія.
//PascalABC.NET
//Версия 3.3.5, сборка 1650
begin
var a:=ArrRandom(30,-100,100).Println;
writeln('положительные числа кратные 5:');
a.Where(x->(x mod 5=0) and (x>0)).Println;
end.
//Версия 3.3.5, сборка 1650
begin
var a:=ArrRandom(30,-100,100).Println;
writeln('положительные числа кратные 5:');
a.Where(x->(x mod 5=0) and (x>0)).Println;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для написания программы вывода на экран положительных чисел массива, кратных числу 5, в языке программирования Паскаль, следуйте следующему коду:
pascalprogram PositiveMultiplesOf5; const MaxArraySize = 100; // Максимальный размер массива var arr: array[1..MaxArraySize] of Integer; n, i: Integer; begin // Ввод размера массива Write('Введите размер массива (не более ', MaxArraySize, '): '); ReadLn(n); // Ввод элементов массива WriteLn('Введите элементы массива:'); for i := 1 to n do begin Write('Элемент ', i, ': '); ReadLn(arr[i]); end; // Вывод положительных чисел массива, кратных 5 WriteLn('Положительные числа массива, кратные 5:'); for i := 1 to n do begin if (arr[i] > 0) and (arr[i] mod 5 = 0) then WriteLn(arr[i]); end; end.
Программа запрашивает у пользователя размер массива и затем просит ввести элементы массива. После ввода она выводит на экран положительные числа массива, которые кратны 5.
Похожие вопросы
Информатика 23
Информатика 76
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
