 
Вопрос задан 01.08.2023 в 03:44.
Предмет Информатика.
Спрашивает Ильин Вадим.
Помогите написать программу на c# Работа с текстовыми файлами: имеется текстовый файл. Выяснить,
имеется ли в нем строка, начинающаяся с буквы «т». Если да, то определить номер первой из таких строк. Условие: текстовый файл для задания заранее создать в текстовом редакторе 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Ахмадуллин Руслан.
                
                   Using System;              
using System.IO;
              
internal class Program
{
public const string FILE = "test.txt";
              
private static void Main()
{
try
{
using (var sr = File.OpenText(FILE))
{
string line;
for (var i = 0; (line = sr.ReadLine()) != null; i++)
{
if (!string.IsNullOrWhiteSpace(line) && line.Trim()[0] == 'т')
{
Console.WriteLine($"Строка {i} = {line}");
break;
}
}
}
}
catch(Exception e)
{
Console.WriteLine(e);
}
finally
{
Console.ReadLine();
}
}
}
              
              
              
                                        using System.IO;
internal class Program
{
public const string FILE = "test.txt";
private static void Main()
{
try
{
using (var sr = File.OpenText(FILE))
{
string line;
for (var i = 0; (line = sr.ReadLine()) != null; i++)
{
if (!string.IsNullOrWhiteSpace(line) && line.Trim()[0] == 'т')
{
Console.WriteLine($"Строка {i} = {line}");
break;
}
}
}
}
catch(Exception e)
{
Console.WriteLine(e);
}
finally
{
Console.ReadLine();
}
}
}
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Для выполнения данной задачи вам понадобится использовать язык программирования C# и классы для работы с текстовыми файлами. Вот пример программы, которая выполняет указанное условие:
csharpusing System;
using System.IO;
class Program
{
    static void Main()
    {
        // Путь к текстовому файлу
        string filePath = "путь_к_вашему_файлу.txt";
        // Метод ReadAllLines читает все строки из файла в массив строк
        string[] lines = File.ReadAllLines(filePath);
        int lineNumber = 0;
        bool found = false;
        // Перебираем все строки
        foreach (string line in lines)
        {
            lineNumber++;
            // Проверяем, начинается ли строка с буквы "т" или "Т"
            if (line.TrimStart().StartsWith("т") || line.TrimStart().StartsWith("Т"))
            {
                found = true;
                break;
            }
        }
        if (found)
        {
            Console.WriteLine($"Первая строка, начинающаяся с буквы 'т', находится на номере: {lineNumber}");
        }
        else
        {
            Console.WriteLine("В файле нет строк, начинающихся с буквы 'т'.");
        }
    }
}
Прежде чем запустить программу, замените "путь_к_вашему_файлу.txt" на фактический путь к вашему текстовому файлу.
Программа считывает все строки из файла, затем проходится по ним в цикле и ищет первую строку, начинающуюся с буквы "т" (или "Т"). Если такая строка найдена, программа выводит ее номер. Если такой строки нет, программа выведет сообщение об этом.
 0
                    0
                     0
                    0
                Похожие вопросы
 
			
                Информатика   35 
            
         
			
                Информатика   76 
            
         
			
                Информатика   93 
            
         
			
                Информатика   27 
            
         
			
                Информатика   142 
            
         
			
                Информатика   51 
            
         
			
                Информатика   119 
            
        Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			