Вопрос задан 31.07.2023 в 01:46.
Предмет Информатика.
Спрашивает Замятина Маша.
Составить программу и блок-схему, которая запрашивает ввод температуры тела человека и определяет,
здоров он или болен (здоров при 36 < t < 37)Ответы на вопрос
Отвечает Бесмертний Вадим.
Var a: real;
begin
write ('Введите температуру');
read(a);
if (a>36) and (a<37) then writeln ('Здоровы') else writeln ('Больны');
end.
begin
write ('Введите температуру');
read(a);
if (a>36) and (a<37) then writeln ('Здоровы') else writeln ('Больны');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Хорошо! Вот программа на языке псевдокода и соответствующая блок-схема для определения, здоров ли человек, основываясь на введенной температуре:
Псевдокод:
markdown1. Вывести сообщение: "Введите температуру тела (в градусах Цельсия):"
2. Считать введенную температуру и сохранить в переменную t
3. Если t > 36 и t < 37, то
4. Вывести сообщение: "Человек здоров."
5. Иначе,
6. Вывести сообщение: "Человек болен."
7. Конец
Блок-схема:
lua+-----------------------+
| Введите температуру: |
+-----------------------+
|
v
+-----------------+
| Считать t |
+-----------------+
|
v
+-----------------+
| t > 36 и t < 37 |
+-----------------+
/ \
v v
+----------------+ +----------------+
| Вывести "Здоров" | | Вывести "Болен" |
+----------------+ +----------------+
Программа запрашивает у пользователя ввод температуры тела в градусах Цельсия, а затем проверяет условие (36 < t < 37) и выводит соответствующее сообщение о состоянии здоровья.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
