Вопрос задан 31.07.2023 в 00:56. Предмет Информатика. Спрашивает Ямлихина Аделя.

1. Напишите программу, которая находит максимальный и минимальный из чётных положи- тельных

элементов массива. Если в массиве нет чётных положительных элементов, нужно вывести сообщение об этом. 2. Введите массив с клавиатуры и найдите (за один проход) количество элементов, имеющих максимальное значение. 3. Найдите за один проход по массиву три его различных элемента, которые меньше всех ос- тальных («три минимума»). 4. *Заполните массив случайными числами в диапазоне 10..12 и найдите длину самой длинной последовательности стоящих рядом одинаковых элементов На питоне пожалуйста!)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Коваль Макс.
задача 1.
a=input().split()

f=-1

for i in range(len(a)):

    if int(a[i])>0 and int(a[i])%2==0:

        if f==-1:

            min1=int(a[i])

            max1=int(a[i])

            f=1

        elif int(a[i])>max1:

            max1=int(a[i])

        elif int(a[i])<min1:

            min1=int(a[i])

if f==-1:

    print('not solution')

else:

    print('max=',end='')

    print(max1)

    print('min=',end='')

    print(min1)

задача 2.

a=input().split()

k=0

max1=float(a[0])

for i in range(len(a)):

    if float(a[i])==max1:

        k+=1

    elif float(a[i])>max1:

        k=1

        max1=float(a[i])

print(k)

задача 3.

a=input().split()

min1=float(a[0])

min2=float(a[0])

min3=float(a[0])

for i in range(len(a)):

    if float(a[i])<min1:

        min3=min2

        min2=min1

        min1=float(a[i])

    elif float(a[i])<min2:

        min3=min2

        min2=float(a[i])

    elif float(a[i])<min3:

        min3=float(a[i])

print(min1)

print(min2)

print(min3)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Давайте решим каждую из четырех задач на Python:

  1. Нахождение максимального и минимального из четных положительных элементов массива:
python
def find_max_min_even_positive(arr): max_even_positive = None min_even_positive = None for num in arr: if num > 0 and num % 2 == 0: if max_even_positive is None or num > max_even_positive: max_even_positive = num if min_even_positive is None or num < min_even_positive: min_even_positive = num if max_even_positive is None or min_even_positive is None: print("В массиве нет чётных положительных элементов.") else: print(f"Максимальный чётный положительный элемент: {max_even_positive}") print(f"Минимальный чётный положительный элемент: {min_even_positive}") # Пример использования array = [1, 5, 10, 7, -2, 4, 6, 3, -9] find_max_min_even_positive(array)
  1. Подсчет количества элементов с максимальным значением в массиве:
python
def count_max_elements(arr): max_value = max(arr) count = arr.count(max_value) print(f"Количество элементов с максимальным значением ({max_value}): {count}") # Пример использования array = [3, 5, 7, 3, 9, 5, 7, 2, 9] count_max_elements(array)
  1. Поиск трех минимальных элементов массива:
python
def find_three_min_elements(arr): min1, min2, min3 = float('inf'), float('inf'), float('inf') for num in arr: if num < min1: min1, min2, min3 = num, min1, min2 elif num < min2: min2, min3 = num, min2 elif num < min3: min3 = num print(f"Три минимальных элемента: {min1}, {min2}, {min3}") # Пример использования array = [5, 3, 7, 1, 9, 2, 8, 4, 6] find_three_min_elements(array)
  1. Заполнение массива случайными числами и нахождение длины самой длинной последовательности стоящих рядом одинаковых элементов:
python
import random def find_longest_sequence_length(arr): current_length = 1 max_length = 1 for i in range(1, len(arr)): if arr[i] == arr[i - 1]: current_length += 1 else: current_length = 1 if current_length > max_length: max_length = current_length print(f"Длина самой длинной последовательности: {max_length}") # Заполним массив случайными числами в диапазоне 10..12 array = [random.randint(10, 12) for _ in range(20)] print(array) find_longest_sequence_length(array)

Примечание: Все программы могут быть запущены отдельно, исходя из вашей конкретной задачи.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос